Why do my headings get automatically indented in Writer?

Why do my headings get automatically indented in Writer?
I have tried to modify the paragraph style, but I just can’t seem to figure out what setting is making my headings get an indentation. My suspicion is that it has something to do with numbered lists, but I could be wrong.
I recorded a small video in case it helps to demonstrate the problem and the settings that I have.

Thank you!

I guess you have an indent set in Tools > Chapter numbering but with None in Numbering tab.
Option the dialogue in Position tab set indent Aligned at to zero

Your video is of little use as you have not enabled View>Formatting Marks which could have revealed the nature of the indent. Obviously, you add direct formatting over Heading n paragraphs.
Your question allude to “numbered lists”. But we can’t see if you attempted to add a number or bullet with toolbar buttons related to numbered lists. If you have one so, you created a numbering conflict on your heading. And even if you removed the numbering with the toolbar button, this kind of direct formatting damaged the Heading n definitions.
Heading n are associated with a dedicated numbering sequence controlled by Tools>Chapter Numbering. If you overspecify with list numbering, Writer gets confused and behaviour becomes unpredictable.

The only way to diagnose your problem is to analyse your document. So edit your question (don’t use a comment) to attach your sample file and mention OS name and LO version.

Hi @ajlittoz!
I tried to edit the main post like you suggested, but unfortunately it seems like some time limit had been reached for editing it, so I’m instead posting the file here:
reproduce heading problem on windows.odt (57.7 KB)
I don’t know if it helps, but I was not able to reproduce this on an Ubuntu machine using the same document, but I got the behavior on my Windows 10 machine.
To reproduce: Select the regular text and apply a heading paragraph style to it. The heading should get automatically indented.


Thanks for your suggestion @EarnestAl!

Unfortunately that didn’t seem to be the case here, those were all already set to 0.

I think there is some corruption in the document. If I copy everything in the document and paste normally into a new document the Headings work OK.

Version: (X86_64) / LibreOffice Community
Build ID: fcbaee479e84c6cd81291587d2ee68cba099e129
CPU threads: 8; OS: Windows 10.0 Build 22621; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: CL threaded

Thanks! That seems to have fixed the issue with me as well.

I had a look at the document. As @EarnestAl suggests your document may have encountered some corruption. Its structure is “normal”. But everything behaves as if chapter numbering properties (number followed by a tab) were taken into account despite the fact there is no number. This can probably be explained only by the edit history of the document (modified 1648 times according to metadata).

By chance, have you ever tried to add to some Heading n paragraph a list number with a toolbar button or Format>Bullets & Numbering in the past (overspecification)? Then removed it?

I didn’t see any trace of .docx intermediate step but have you ever saved the document in this format before converting it back to .odt?

A similar issue was reported last December on the French OpenOffice forum. See the topic Supprimer les tabulations de titre.
The workaround given was to choose Tools → Chapter Numbering → Position tab and set “Numbering followed by” to Nothing.

You mean 1468 times?

The question about the relationship with .docx is relevant, as it was in the French topic mentioned above.

On the other hand, unpack the document and take a look at the internal file settings.xml. There is a parameter called NoNumberingShowFollowBy:

<config:config-item config:name="NoNumberingShowFollowBy" config:type="boolean">true</config:config-item>

Change its value to false or remove the whole entry, repack the structure and observe the result in UI.

It is then a corruption of the document as suggested by EarnestAl or something else?


Yes I have edited that file a lot, it contains a huge amount of my notes for different software etc.

I don’t think it has ever been a .docx but one weird thing that might be in its edit history is that I’m using Nextcloud and I did try the Nextcloud’s built in editor for the file a few times, until I realized it seemed to mess up the integrated table objects that I have in the document. So since Nextcloud seemed to mess with that somehow, it might be plausible to assume that it might have created this other issue as well.