Why do new versions of LibreOffice look weird?

Recently, I’ve updated to the new versions of LibreOffice, but they look much different for some reason. I’ve noticed that it’s caused by my GTK3 theme, but I just want it to look like the older versions of LibreOffice, because they look normal.

I’m running KDE Plasma on Kubuntu.


image description


Edit your question to report the output of Help>About LibreOffice (detailed version information). You may have not installed the correct VCL.

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

I’ve noticed that it’s caused by my GTK3 theme …
… I’m running KDE Plasma.

If you’d really running LibreOffice with KDE Plasma then GTK3 would not play a role. Hence you seem to not have installed the required libreoffice kf5 support packages which are required to run LibreOffice correctly as KDE Plasma application.Since you did not mention your GNU/Linux distribution, the exact package name to check/install cannot be given.

Hello, I’ve updated my question to have more detailed information. Also, I’m using Kubuntu.

In your, the VCL module is kf5 which is the correct interface for the Qt-based widgets under KDE Plasma.

In your, the VCL module is gtk3. This is what causes the issue. Gtk3 is adapted for the GTK+ widgets of GNOME or MATE.

To fix the problem, install the libreoffice-kf5 package and don’t forget to disable or uninstall libreoffice-gtk3. These are the names under Fedora, adapt to your case.

But you probably installed directly from LO site, so I don’t know if there is such a separate module available there. If you installed from your distro repositories there should not be any problem.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.


you seem to use flatpak (see your screenshot under Misc:) and flatpaks don’t support KDE Plasma but use GTK3. Please read: LibreOffice in Flatpak format | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft which states:

The LibreOffice Flatpak is using LibreOffice’s GTK3 backend, which should offer the most complete set of features in LibreOffice, including support for Wayland. Older versions of the LibreOffice Flatpak were based on the GNOME runtime, but starting with LibreOffice 6.0.3 it is based on the smaller freedesktop.org runtime, which should not have any negative impact on functionality.

Hence, if you want KDE Plasma Support, use Ubuntu PPA for LibreOffice “fresh” by performing:

  • Deinstall the flatpak version
  • sudo add-apt-repository ppa:libreoffice/ppa --yes
  • sudo apt update
  • sudo apt install libreoffice libreoffice-kf5 libreoffice-sdbc-hsqldb libreoffice-help-en-us --yes

Hope that helps.

Thanks for the answer. I think it partially worked because now LibreOffice doesn’t open without showing an error.

You can view the image by clicking here.

I’m not a user of flatpak, but you seem to have deinstalled flatpak while you should have deinstalled “LibreOffice flatpak version” using flatpak command. In other words flatpak is the command to manage flatpak versions of application (something like flatpak uninstall org.libreoffice.LibreOffice should do that, but as stated: I don’t use flatpak).

> LibreOffice doesn't open without ...

Sure, if you removed flatpak command itself, the start command flatpak run org.libreoffice.LibreOffice (or similar) no longer can be executed)

I ran flatpak uninstall org.libreoffice.LibreOffice and the new versions of LibreOffice have been removed. What do I do now?

Nevermind, LibreOffice is updated! Thanks a lot for the help!

This is step 1 from my answer - did you execute the 3 other steps?

Yes, I did.