Why does a deleted autocorrect word keep reappearing?

It’s driving me nuts!
I misspelled a word in Writer and autocorrect gathered it up as an option. I spotted this, went in to auto-correct options, selected word completion and deleted the misspelled word, but every time it just reappears. It even tries to use the misspelled word when having deleted it, it isn’t even there on the autocorrect word completion list, but it’s still the first option. It’s a word I am using frequently in something so I can’t just ignore it.
I’ve tried closing and reopening the document. I’ve tried opening a new document. I’ve tried shutting down and restarting my computer. I’ve tried not headbutting my computer…

Any assistance so I can actually do the writing I was trying to would be much appreciated.

I do not know if the following bit of advice works with LO/OO, but it does work with Firefox:-

Replacement suggestions may be permanently removed by pressing the Delete button whilst they are highlighted as a replacement.

(else, try the following):

This sort of stuff gets stored in your user Profile. As it is still there after OS reboot then try a Profile reboot:-

A corrupt profile can cause such problems. Fortunately, it is easy to fix (and to reverse):

Re-Setting the User Profile to Fix Corruption:

  1. Close down LO/OO + the Quickstarter
  2. Go to your profile
  3. Rename the folder
  4. Restart the program

    (this re-creates a default Profile)
  5. Restart LO & try again

Note: 5.x currently uses same Profile locations as 4.x

If any of this helps then please tick the answer (:heavy_check_mark:).

This may be easy for you, but none of this makes sense to me. I’m having exactly the same problem and it’s driving ME nuts, too.

That is surely a bug. I virtually never used “Word Completion” but just tried it with 4.4.4 and it did as you described. Even the option ‘When closing … remove …’ didn’t work.

(However, why don’t you switch off that nonsense? (That, at least, worked for me.))

A bug report concerning the issue was filed as tdf#67826. It was confirmed and assigned, but obviously not yet resolved.

(A short test with my V5.0.0.0beta3 showed ‘Word completion’ not working at all.)

Thanks for citing the bug report. It’s been a bug since 2013! Why is it taking so long for this very annoying bug to be taken care of??

Your guess?
Why did so few users comment on that very annoying bug? Why no one for more than a year now?
Did you bump the report giving additional information if available? (At least like "still living in version…)

I came back to this thread only due to a notification which I got because I earlier had posted into it.
But I’m a user like you. It’s very likely that no developers or Q/A people will even see your comment here.

I think there are few posts about it because the keywords ‘autocorrect’ and ‘word completion’ turn up so many unrelated queries. I, for one, didn’t find a single relevant result in a web search. It was only when I came directly here and posed my own question that this q&a turned up.
Thank you for taking the time to post both your answers here above! I have posted a follow-up at at Bugzilla per your suggestion.

I don’t use AutoCorrect much (and my mind named it AutoSpoil), but I sometimes enable the replacement feature.
The cases where I experienced an “undeletability” I managed it by entering the character-sequence triggering the unwanted replacement left in the table, and exactly the same sequence as its replacement.
Another Workaround (sometimes failing due to missing attention):
While typing under permanent visual control a Ctrl+Z immediately after the unwanted replacement should help.

No reply yet in Bugzilla.

Sorry, I’m not clear on how you do either of those work-arounds. I tried what I thought you meant and they didn’t work.
For #1, do you mean going to AutoCorrect Options and clicking the Replace tab?
For #2, do you mean accepting the unwanted suggestion (in my case, I accept with the return key) and then immediately hitting ctrl-Z?

Ad #1 Yes. The table I talked of was the replacement table.
Ad #2 I don’t understand. AutoCorrect doesn’t suggest anything to me, but simply applies the defined replacement. This replacement can be made undone (Ctrl+Z or via the menu >Edit>Undo if you noticed it as unwanted before having continued with your work.
Didn’t you actually talk of AutoCorrect, but of spell checking? (I next to never use it.)