Why does a short vertical grey line appear when making a semi-colon or colon in LibreOffice?

It’s annoying to look at, and I backspace to the line to delete it. Don’t know if when printing there’s a space where that short grey vertical line is…

In some languages, local typographic rules dictates that several punctuation be separated from the preceding word by an en- or em- non-breaking space. This non-breaking space is shown as a thin grey area. This an auto-correct feature.

If you prefer to do without it, go to ToolsAutocorrect options, then select Language options. You may find here Add a non-breaking space before punctuation. Uncheck “on modification” or “on initial typing” boxes to your taste.

Note: this option does not exist in English; it is known in French for example.

Remember to tick this answer if you think it adequately addresses your problem.


As @ajlittoz says it is probably displaying a non-breaking character. My advice however is different: these AutoCorrections are expected to generate a correct typography depending on the locale (language settings). It is generally advisable to keep this AutoCorrection. This gray character is not printed as is, it is only used on screen to draw the user’s attention. If this view bothers you it is possible to disable: uncheck ViewField Shadings (Ctrl+F8).