Why does F1 still take me to the web after installing resident help file?

I upgraded to and then installed the resident Help file. However, when selecting “Help” or pressing F1, the program still takes me to my browser and tries to access the internet. With version 3.4, I had no such problem. I’m using Windows XP Home, with Service Pack 2 and all the latest Windows patches/etc. from Microsoft.

AS stated by DeanK
"On Windows XP Pro, using LibreOffice English version (en-GB):

go to C:\Program Files\LibreOffice 3.5\Help, there will be a en-BG (English version) folder. Select all the files in the folder, cut and paste it into the C:\Program Files\LibreOffice 3.5\Help folder, delete the en-GB folder(now empty).

Then go to Control Panel and click on “Application/Product Installer” (I don’t remeber the right name beacuse I’ve Italian language installed; anyway it’s the “box with a little CDROM beside”!). Look for your LibreOffice release installed, then click on it to MODIFY-ADJUST the installation.
Once LibreO. installer started and you choosed the modify choice, it will be prompted a tree with all the feature still present and those you might need. Go inside the “User Interface Language Support Branch” and choose ENGLISH UK. Then confirm and go on with the install interface (wait untill it’s finished).

I made some experiments and there’s no need to uninstall and reinstall all the application, unless some chaos has been made before to start our changes.

Many Thanks to DeanK!!!
This helped me because LibreO. comes with UI-English(US) by default in
its installation process, without any other UI-Language selected; when I ran the installer I didn’t configured UI-Language.

This worked perfectly, thank you sooooo much!

Check in the Control Panel’s Add/Remove Programs list if after “LibreOffice 3.5” there is a “LibreOffice 3.5 Help Pack (your selected language)”

I posted the original question. I’ve checked the Add/Remove program list and the LibreOffice Help Pack is listed with the correct language. I think the main LibreOffice program doesn’t recognize the help pack. It’s very frustrating.

I suggest that you uninstall the help package, reboot, delete the contents of C:\Program Files\LibreOffice 3.5\help (don’t delete the folder, just the contents). Download LibreOffice 3.5.2 and the corresponding help package. Install version 3.5.2 and then the new help pack.

I am having the same issue after upgrading to the same version Windows Vista). I checked my control panel, and indeed the help files are showing as installed. I did repair the installation from there in case that would help, but that has yielded no results.

I would suggest that you uninstall it and check if the C:\Program Files\LibreOffice 3.5\help is empty (if not delete any content manually) and then download again the help package from http://download.documentfoundation.org/libreoffice/stable/3.5.1/win/x86/ and reinstall

Yes-when I saw the other was Russian-I did not install it-I have the Eng help files installed for the second time-still it takes me to my browser.

Thank you Pedro for your response. The link you gave led to an installation of the help files was in Russian. I had un-installed all the help files, and manually deleted the folder and reinstalled from the main download page: http://www.libreoffice.org/download/ and it is not working. Is it possible that the main download link for the help files is corrupt?

The help file is not corrupted (I tested). There is some problem in your PC. Please follow the instructions on my comment to Kweko (two answers above) and report your findings.

I have reinstalled everything, once again, and it has not made any difference. I now have LibreOffice
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f

Another suggestion: Close LibreOffice.Click on Start, Run… Type or paste this %AppData%\LibreOffice and press Enter. In the opened folder (which contains your LibreOffice profile) rename folder 3 to 3.old and then restart LibreOffice twice (the first time creates a new 3 folder)

Yes, thank you. I tried that too, and it does not work. In the earlier versions, I had the help file installed internally. Could it be a bug?

Did you try this now after installing version I use daily the internal Help file under Win XP (mine is SP3 but I doubt that is the problem) so it is clearly a problem but not a systematic bug…

Yes I did-oh well-does not seem to want to be solved. On a good note, other than this, there is a lot of improvement in this program.

Yes, LibreOffice is improving at a steady pace :slight_smile: Regarding your help problem, apparently the language for the help file must match the user interface. Could it be that you are using the English (UK) interface? See this topic http://en.libreofficeforum.org/node/461

On Windows XP Pro, using LibreOffice English version (en-GB):
Uninstall LibreOffice and the LibreOffice Help Pack from Add/Remove programs. Delete the C:\Program Files\LibreOffice 3.5 folder. Install LibreOffice and the Help Pack. After the installation have completed go to C:\Program Files\LibreOffice 3.5\Help, there will be a en-BG (English version) folder. Select all the files in the folder, cut and paste it into the C:\Program Files\LibreOffice 3.5\Help folder, delete the en-GB folder(now empty).

For me that didn’t work. I have Win XP SP3, LibreOffice I already had English-US chosen in the UE and I also had installed the English-US offline help. But I had chosen not to install into the Default C:\Programme (the German version of C:\Program Files), but into my own preferred C:\bin . Yet it turned out that Libre Office only partly installed itself in C:\bin. Also I choose otherwise partly it was nevertheless installed in C:\Programme !
I uninstalled LibreOffice and the offline help and re-installed it in the default C:\Programme and now offline help works.

Regards, Marvin.

I’ve experienced this problem for some time but never got round to resolving it. I’ve just upgraded to the 4.0 release and decided to sort it out. My solution was slightly different (and easier) from that posted by DeanK so thought I would share it.

There was no need to copy/paste the help files to a different location or run the installer. Simply open up the Tools->Options->Language Settings->Languages dialog and make sure the “Language of User Interface” is set to English (UK). Restart LibreOffice and you should find F1 now launches offline help.