Why does Impress jump (pan) when I zoom in to graphic details?

I’m zoomed in at (say) 300% to fine-tune a drawing detail. My screen has been carefully arranged – maybe I’ve entered
into a group to edit one member. When I zoom in a little more, Impress 5.0 overrules my intentions, and by itself
decides to pan a few inches over – presumably to fit some object. This default jumping around destroys my setup, and makes it difficult to fine-tune complex engineering diagrams. Is there any way to disable it?