Why does Libreoffice 4.2.2 use the high performance GPU on my laptop running OS X 10.9.2?

This issue significantly reduces the battery life and as far as I know it is unnecessary because when I was running 10.6.8, the same version of Libreoffice didn’t switch to the high performance GPU. Is there a reason or a fix for this?

Is it happening with all files or one particular file?

It doesn’t seem to matter which file is open. If I open a file from by double clicking in finder everything is fine, but if I open libreoffice and then click open, that triggers the graphics switch and it then doesn’t switch back.

I should add “until I quit libreoffice” to the end.

See if playing with the options in Menu/Tools/LibreOffice/View - Graphics output, change something.
Another thing to try is resetting the user profile, sometimes solves strange issues.

Sadly neither of those suggestions work, thanks for the help though. The only option I could change in the graphics output was anti-aliasing and it didn’t have an effect. Maybe it’s an OS X problem.

Please what is your LibreOffice version?

It says in the about Libreoffice info.