Why does LibreOffice Base not recognise JRE but does recognise JDK?

I’m running LibreOffice with Windows 10 and installed JRE 1.8.0_191 (x64) so that I could get the wizards to work. However when I go to Tools/Options/Advanced and select my Program Files (x86)/Java/jre1.8.0_191 folder, it tells me the folder does not contain a Java runtime environment. I tried installing the Java JDK and pointed LibeOffice to Program Files/Java/jdk-11.0.1, and this worked and enabled the Wizards. I uninstalled the JRE, and the wizard still works. The error message about not containing a Java runtime environment is totally misleading - is jre not a Java Runtime Environment?? So why does it not tell me I need the JDK instead?
I’m posting this in case it helps someone else to avoid hours of frustration.

Because you have wrong JRE installed. LibreOffice 64-bit needs JRE 64-bit. On the other hand, your JDK includes 64-bit JRE.

And 6.1 should have mentioned the platform requirement in the “JRE not found” message. We added that to help people recognize that. But it seems that no amount of information will ever be enough.

It also seems a waste of the 100+ answers in this forum specifying that 64-bit LO needs 64-bit JRE and 32-bit LO needs 32-bit Java (found in Program Files (X86)). Although JDK contains JRE, only Mac truely needs this.

Mike is correct - “…no amount of information will ever be enough.”

Ok, I mistakenly thought that x86 was 64bit so I THOUGHT I’d installed the correct jre, as I’d already read the comments about needing the correct version. I still think the error messaging could be more helpful for non-geeks. And some sort of error message about requiring the jre to run the wizard would be helpful, instead of just nothing happening.