Why does LO7 look bad?

Libre Office’s interface looked like this in version 6:
alt text

And now it looks like an antique Windows 95 application in LO7:
alt text

How can I fix this or will it be fixed in a future release?

Beauty is in the eye of the beholder.
Presentation is under the control of the toolkit.

Toolkit? How do I manage that?

Sorry. I currently am not a Linux user, and I know too little about the details insofar.
My above comment wasn’t intended to give the answer to your question. Read it as a literary flourish.
I assume @anon73440385 will soon edit his answer adding more detais probably solving your problem.
Hopefully I will be able next time to withstand the tempation to post another comment of the kind.

Toolkit? How do I manage that?

Toolkit is a set of libraries which define the look&feel of a graphical environment. e.g the GTK makes all applications using that toolkit look the same with respect to buttons, menus and other repeating elements of applications. That’s why it was immediately clear, that your problem is related to the toolkit support of the application (and a missing package).


probably you are using your LibreOffice on a GNU/Linux distribution and you are missing either KDE --or-- GTK3 support packages and therefore your are running fallback/generic VCL=x11 (see Help -> About LibreOffice). But your question doesn’t provide:

  • Operating system / Linux Distribution information
  • Desktop Manager (GNOME, KDE/Plasma, MATE, XFCE, LXQt …)
  • LibreOffice Package repository (TDF=libreoffice.org, Distribution repos)
  • LibreOffice type of installation (Default packaging, snap, AppImage, flatpack)

Hence this answer needs to be incomplete until you provide these information. Search your repository for the support packages that match your desktop environment and install the proper one (from the look&feel of your first screenshot, I’d assume that you are using a GTK3-based desktop manager, may be GNOME)


openSUSE Leap 15.2

$zypper search libreoffice | egrep "qt5|kf5|kde|gtk3"
| libreoffice-gtk3      | GTK+ 3-Benutzeroberfläche für LibreOffice                  | Paket
| libreoffice-qt5       | Qt5/KDE-Frameworks-Schnittstelle für LibreOffice           | Paket

Ubuntu 20.04

$apt search libreoffice 2>/dev/null | egrep "kf5|gtk3" 
libreoffice-gtk3/focal 1:7.0.1~rc1-0ubuntu0.20.04.1 amd64
libreoffice-kf5/focal 1:7.0.1~rc1-0ubuntu0.20.04.1 amd64

[Update] After availability of additional system information

Use dpkg --install libobasis7.0-gnome-integration_7.0.0.3-3_amd64.deb (This package is part of the LibreOffice_7.0.0.3_Linux_x86-64_deb.tar.gz tar archive).

Hope that helps.

@anon73440385: thanks for the help. :slight_smile:

The command you suggested to check LO looks like this:

$ apt search libreoffice 2>/dev/null | egrep "kf5|gtk3" 
i   libreoffice-gtk3                - office productivity suite -- GTK+ 3.0 inte
p   libreoffice-gtk3:i386           - office productivity suite -- GTK+ 3.0 inte

So it looks like I do have a package that provides GTK3 looks. But it doesn’t seem work for LO7 in my old distro.

I installed/upgraded LO from the package on the LO website

Then apt search is worthless. You need to install the proper .deb package from TDF (LO website). Please see the [Update] in my answer.

@anon73440385: thanks for the tip. :slight_smile: I installed everything, like described in the readme (sudo dpkg -i *.deb). To be sure I installed the package you mentioned via your method. Elas, LO7 still looks like Win 95.

Hmm … I got no such old Mint system (my oldest one is Mint 18.3). You may try the following (for testing purposes):

  • open a terminal
  • Execute: SAL_USE_VCLPLUGIN=gtk3 libreoffice7.0

Does this work? Do you see any errors (besides java related ones)?

Update Just tested to install LibreOffice on Mint 18.3 and got no problem using VCL:gtk3, while LibreOffice immediately crashed when using Help -> About LibreOffice

Unfortunately: nope it don’t. I tried LO ver. (which you refer to). Had to Google it (the official download on Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft is ver. Maybe LO7 isn’t stable enough yet. On the LO website the “stable” version is 6.4.6. I need a newer LO version because a very, very old nasty bug in automatic Chapter Numbering in DOCX docs has finally been fixed after 5+ years in LO7.

If I do Help -> About LibreOffice (ver as well as it does not crash. It shows “User interface: UI render: default; VCL: x11”. That X11 should be GTK3 I think…

I’ll be patient then…

Don’t expect that to get fixed by waiting with patience (and I’d assume that is with your old Mint release being based on Ubuntu 16.04 and thus having an old GTK3 toolkit, since on newer MINT it does work)

Yeah, you’re right. I’m gonna have to upgrade my distro. I was more talking 'bout the stability of the current LO release. Thanks for the help and the info! :slight_smile:

I have no issue on one device running Ubuntu 20.04.
On another device with same ubuntu, LO ppa and LO version, I have this same issue.

The difference I can tell is that on the second device with this issue I installed using:

sudo apt install libreoffice qpdfview --no-install-recommends

Hope this helps to find the problem.

I made some searche and came back with this solution

sudo apt install libreoffice-gtk3

Worked for me. Hope this will work for everyone too!