Why does Writer keep reverting from Default to Normal style? [solved]

I have a Writer document that keeps reverting the style from Default to Normal. I even do a Crtl-A to select the whole document, then I apply the Default style. Then, if I go to the end of the document and press Enter, it reverts to Normal.

I’ve searched through all of the settings and cannot find what is causing this.

Anybody know what’s going on and how to stop this behavior?

Thanks!

Has this Writer document ever been a Word document? Perhaps based on a Word template?

Well, I can’t say for sure 100% no, but I don’t think so.
Should I try copying all the data to a new .odt file and paste with no formatting?

Thank you keme, your comment gave me that idea. I should’ve tried that anyway. I copied all of the text and copied it into a new .odt document using Unformatted Text. For now that seems to have cured it.

Thanks for the tip!

You should be using Text Body for the normal text. If you look at the Headings styles, the next style is Text Body so you will be fighting to keep Default Paragraph anyway.

Default Paragraph is a reference style rather than style you would use in a document. Paragraph styles are inherited from Default Paragraph.

Text Body”, Oh okay! Well, I’ll admit, I never read up on the proper way to use the styles. Thanks for the enlightenment Earnest. If I remember correctly, every new, blank, Writer document I ever created had the Default style already selected. So I assumed (Incorrectly I guess) the Default style was the one I was supposed to work with, by default. Ok, I’ll look into using the Text Body style.

If you don’t want to think abut it too much, in Tools > AutoCorrect > AutoCorrect Options > Options you can tick the Styles box. Click Help to see details but pretty much as below.

When you start a new paragraph on a new document, as soon as you hit Return it will change the style to Text Body anyway. If you want to start with Heading 1, you can type the text and hit Return twice and it will make that paragraph Heading 1 and take you to the start of a Text Body paragraph.

Thanks everybody! Thru this conversation I have learned a lot more about styles and the use of them. Most importantly, in answer to my original question I have learned that if you have “Text Body:” set as the “Next style:” , after pressing Enter twice, Writer will switch to that style.
Thanks for helping!