Why doesn't the 'Author' field contain my name?

I cannot get the Author field to populate. I have entered my name in Options → LibreOffice → User Data which is, I believe, the source of the Author field. If I insert a comment, my name appears in the comment box. I can successfully insert other fields eg date, time, page number into my document but the Author field, while inserting, does not populate with my name. Any help appreciated.

Thanks. Problem solved.

You likely created your document before setting your user data. Now pick File → Properties → General (tab) and press “Reset” button next to “Use personal data” to claim it yours.

Perfect answer.