Why has my use of 1st been automatically changed to 1*

I have recently upgraded to In Writer, I now discover that my previously frequent use of “1st” now automatically changes to “1” plus “st” in superscript, which is illegible. I use super- and sub-scripts, but this use is not to my preference.

1> Why, typographically/grammatically? I can imagine this is not preferred, but I’m only writing a draft.
2> How can I change this apparent “default”?

Also, spell check options, etc, do no appear to be accessible from the “Options” dialog. Is there a specific reason for this? How are we supposed to think about where our various option controls are to be found?

The default behaviour has likely (questionably) been changed for English. AutoCorrection of ordinals to superscript is a locale-based consideration (refer tdf#89437). The related help page is here.

Great! and thanks.