Why is a "text import" window now appearing when I open my Calc files?

I have LibreOffice 3.3.3, has worked well for a year on a Windows 8 (recently updated to 8.1) asus vivotab hybrid (tablet/laptop). Recently, out of nowhere, when I opened my Calc files (ods), a “text import” window appears before the file opens. If I click “ok”, the file comes out blank. If I open a .doc file, a similar “text import” window appears, and if I hit “ok” the file opens a page with rows and rows of “###########”. If I click “cancel” in the “text import” window, the file doesn’t open in both cases.

I have master template Calc files which I can copy/paste to another folder, then re-name and open and it works just fine. I can add text/numbers to these files, close and then open them and they work just fine. But when I shut down my computer and open them the next day, the “text import” window appears. (and the files are now blank.) This problem appeared after upgrading to 8.1 from windows 8, but not right away so I’m not sure if there is a correlation. I have since run System Mechanic, Advanced System Care (paid versions) and Defender, but it has not fixed the problem. Any Ideas? (btw, I have not upgraded to a higher version of LibreOffice as the formulas in my Calc files for some reason don’t translate/work in the higher versions, but that’s another question I will have to pose later)

Please upload an example file elsewhere and edit your question to include a link. It may be that your files are not saved in the format you are expecting.

Hi everyone… I’m the person who asked the question, but was not sure what to do when I found my answer… was I to edit or just reply with an answer…? anyways, I’m replying.
I found a post in the forum that lead me to what I thought might be a solution. So I went to the file in question and left clicked on it and selected “properties”. I was looking to see how the file was associated. The Properties window that came up has, of course, 3 tabs: General/Document Statistics/Details … as I was looking around I clicked the Document Statistics tab and another window came up that read:

ProgramC\Windows explore.exe
This application has requested Runtime to terminate it in an unusual way.
Please contact the application support team for more info.

Then I pressed “ok” and the window shut down, as well as blanking out my destop with a blue screen that lingered for several seconds before returning to the regular desktop mode. Btw, I tried this several times and when the RunTime Error came up, I just had to wait for a minute or so and it would close it and the “properties” window down even if I didn’t hit “ok”.

I guess the file was corrupted. The only thing I could think of was this file was on a cheap OEM brand micro SD card I had installed to expand my memory(You know, the 64 GB ones that only cost $33.), rather than having the files on the actual hardrive of my computer. I came to this conclusion because any LibreOffice file on my hardrive did not exhibit the same problems as the ones on the SD card. So I went to the extreme and “refreshed” my computer (a feature of Windows 8.1), which put me back to Win 8, then I had 88 updates to unstall :slight_smile: , and then I installed Win 8.1, followed by the fresh install of LibreOffice 3.3.

Although this process was very time consuming, it not only solved my problem, in the process I discovered how SKYDRIVE really works. I mean I guess I could have just transferred my LibreOffice files to my hardrive, delete the few files that were corrupted and take the micro SD out and throw it in the garbage. But I wanted to make sure by doing it the long way.

Anyways, as a side note, I transferred all my LibreOffice folders/files to my Skydrive folder (the one that you access from the desktop mode by clicking the folder in the taskbar that gets you to your file directory). Then left clicked the folders I wanted to have access to offline, and clicked the option “Make available offline”. I now have my folders/files in the skydrive cloud and well as available offline and when I alter any file, it automatically updates the change in the cloud, making it available to all my other computers/tablet/devices. I was even able to create a “tile” shortcut to the skydrive folders I wanted.

Problem solved.

Thanks for reporting back. In this case an answer is more appropriate as you found the problem and a solution.