why is "adjust to contour" dim in text window in Draw?

I am trying to get text to flow with the contours of a draw object in LibreOffice Draw. According to Help (“text” > “text/draw objects”), I should go to the Format menu, select the Text option, select the Text tab, and check the “Adjust to contour” option. Each time I go there, the “Adjust to contour” option is dim. How do I make this option available?

Any help will be much appreciated. Thank you.

I am using LibreOffice in English, and
Mac OSX 10.10.2.

Hi - The option appears to be available only in Writer

A workaround is to create the shape in this module and then copy it into Draw. The option remains available.

“Adjust to contour” and “Fit to frame” is only available for certain kind of shapes. It is available for primitive rectangle (from the rectangle tool box), ellipses (from the ellipse toolbox), for polygons and closed bezier curves. The text box on the other hand has only the two left top options. And the custom shapes have only the two top right options. In all cases the other options are disabled.

The feature “Adjust to contour” has several bugs in never LO versions. If you will use it, you should work with Apache OpenOffice.

Hi @Regina

On windows 7 & Version: this property is not available for rectangles, ellipses created in Draw.

It is for those created in Writer and you can copy them into Draw.


Draw has two kind of rectangles, the “primitive” kind and “custom shape” kind. Click on the rectangle and look into the status bar. Do you read “shape”, then it is a “custom shape” kind. Do you read “rectangle”, then it is a “primitive” kind. To get the “primitive” ones you have to customize the drawing toolbar and add the rectangle toolbox. It is not a matter of Writer or Draw but of the kind of rectangle you use. Same for circles.

@Regina - Thank you for your reply. I know the difference between the types of shape. What I did not notice is that the rectangle was replaced in the default Drawing toolbar by the shape… in Draw and not in Writer