Why is all my text missing?

Starting today, there’s absolutely no text in my screen. I can type text, and the cursor moves and something is being selected, but I can’t see it. All the text is missing, in the entire program. Toolbars, documents, popup windows, buttons. No text at all, anywhere. In the menu bar, there are little dashes or underlines at the beginning of where the word “file”, “edit”, etc are supposed to be, but that’s all. The only text that remains, anywhere,is the words LibreOffice on the titlebar. Every LibreOffice program I have opened is the same.

That screenshot is of a new document I opened and typed in, and selected the text. Nothing shows up. Not the content, not the usual word count text at the bottom of the doc window, no text in the drop down menus, nothing.

I have used LibreOffice on this laptop since I got it. No problems until today. All my other programs are fine. I downloaded a new version. Uninstalled old copy. Installed new copy (5.3.3). Still no text.

Using Windows 7 Home Premium. Currently uninstalling 5.3.3 and trying to install on old download from January 2017. Will post back when I see if that works.

ETA: Uninstalled current version, reinstalled, and all my text is back. I’ll keep this version for a few weeks, and hope the next update works better for me then…

upvoted so that you might post a screenshot

Another OpenGL problem case.

Workperson isn’t the only one to whom this problem happened. Over the past two days, I attempted to download and install Version on my Windows 7 machine through the Google Chrome browser and achieved the same result as described above. I also had MalwareBytes antivirus utility in operation. Very frustrating and worrisome, as I needed to work on various documents.
Fortunately, I still had my installers for Ver. available, so reinstalled successfully.