Why is the default font wrong in new ODT files?

A few days ago, I switched over from OpenOffice to LibreOffice, because it seemed to be the better of the two. As soon as I was basically settled into LO, I uninstalled OO from my computer; this temporarily confused the Windows Explorer context menu into not giving options to create new ODFs, but after setting LibreOffice as my default ODT reader, that snapped back into place.

Unfortunately, when I create new ODT files using the Explorer context menu now, the default font in them is wrong; I’ve changed my default font from Times New Roman Size 12 to Arial Size 10, and that works fine when I create a new text document within Writer, but in the documents I create in Explorer, the default is still TNR 12. At the moment, I’m just manually changing it back each time, but that’s going to be a drag in the long term. Is there any obvious reason this would be happening? And if so, is there any obvious fix for it?

Edit: Ah, yeah, it was dumb of me not to mention my technical details. I’m using Windows 7 Home Premium 64-bit, and LibreOffice

It would be helpful to know which OS you are using.

Good point. I’ve edited my tech info into the bottom of the post.

Alright, I’ve solved it. It turns out that there’s a template document, and when you create a new one in the Explorer context menu, it copies from that. If you go into that document and edit the font settings there, it’ll change them in whatever new ones you create in the future.

To find the document, starting from the LibreOffice installation folder, go to the “share” subfolder, then its “template” subfolder, and then its “shellnew” subfolder. In there, there ought to be a few documents, all named “soffice” but with different file types. If you want to change the default font in new ODTs, edit the font in soffice.odt to whatever you want the default to be. I haven’t tested it, but I imagine the same basic method would work for other properties.

Also, while I doubt it matters, I figure it’s worth mentioning here just in case it does: When I changed the default font in the template document, I did it through the Basic Fonts sub-bit of the options menu, rather than the font selection menu in the top-left section of the interface.

See also:
When I’m starting program it is no language to check spelling

I tried exploring that on my copy of Windows 7 SP1 with LO and couldn’t get it to default back to TNR 12 when I reopened a test file. What version of Windows are you using? Also, are you using LO yet? This may be a bug in the download you have. I would try keeping the saved document and re-install from a fresh download. But get if you don’t have it yet. Give that a try and see what happens.

Also, I just thought of something. Uninstalling OpenOffice might have left behind a cache file or files still registering. These files could possibly have a small effect on how LO performs. LO finds part of it’s original code within OpenOffice, so these might interact as if they are being called by OpenOffice code, when really it’s OO code integrated into LO. Huh? Let’s see if I can make that any more confusing. Just going out on a limb with that in my thought processes.

Alright, I tried the reinstall and got nothing. Yes, I am using And that last paragraph sounds like it could be something worth pursuing; I deleted whatever leftover OO files I could find in my AppData folder and it didn’t do anything, but for all I know there’s another cache somewhere that I missed.