Why is the "Maximize" button not visible on first-opened files? (Linux Mint 19.3 Cinnamon)

EDIT 2: Seems “Text scaling factor” (a setting in Linux Mint) is the culprit. When it’s 1.3 and above, the Max button disappears and follows behavior in my OP below.

EDIT 1: Probably worth mentioning that this happened after a set of OS updates.

Hello. Only the Minimize and Close buttons are visible, at the upper-right corner, on the first file I open. Succeeding opened files show all 3 buttons (including Maximize). Cycle repeats whenever LO closes/exits. Thank you.

Your post describes a symptom, but do you have a question or is it intended to make people (may be developers) aware of a problem?

Just upgraded to 19.3 on my Mint test system and cannot confirm the behavior. All opened files (i.e. their respective window) show all 3 buttons (using Launchpad PPA for LibreOffice fresh/latest) . Could you please provide some information on the LibreOffice version and the repository used for the packages being installed?

Thanks for the response. I edited the title and added a sentence in the body, sorry about that. LO version is; it was natively “bundled” with Mint 19.1 when I had it. I didn’t install any PPAs or anything for it, I just follow updates available through Mint’s Update Manager.

Installed from base "bundled* repository (which is in fact Ubuntu’s repository) and still cannot confirm your oberservation. It might sound like a strange idea, but could you test starting LibreOffice in Safe Mode, opening a file an check whether the problem is gone?


  • Open a terminal program
  • Execute: libreoffice --safe-mode
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Click button Continue in Safe Mode
  • Open a file and test whether the problem is gone

If that doesn’t show the problem, you may face a problem in your user profile.

I think I just found the culprit. Maybe you can replicate it. Go to Font Selection >> Font Settings >> Set Text scaling factor to 1.3. Restart LibO–the “main” and “blank” LibO (its home window) that shows huge icons of all recent documents. Maximize button isn’t there. If Text scaling factor is 1.2 (and then restarting LibO), Maximize button comes back. Weird. I just noticed this after changing font sizes on my two Mint PCs. Thanks again.