Why isn't LibreOffice rendering graphite based fonts?

This is more of a bug, but I can’t seem to find any references online. So I’ve decided to ask it here and see if anyone can help me with this problem, in hopes that I’m not the only one to suffer this seemingly rare bug.

I have a laptop, which I recentlly reinstalled and put libreoffice on. Only to find that it refuses to render graphite fonts. Both the Linux Libertine (which I quite like and use often), and the Gentium Basic fonts are the only ones affected. The fonts are there, I can select them and I can use them, but they come up as blank, I can’t see anything at all. I’ve tried resetting my user profile, disabling OpenGL and hardware acceleration. Nothing seems to work. When I export the document to a pdf file, the pdf shows the text just fine. The fonts show up in wordpad AND even notepad. But on the LibreWriter screen all I get is a big blank page. I can select the text, I can even spellcheck it. It just doesn’t show on the screen. Even the dropdown font menu will show up a blank line where the fonts are supposed to be.

After some experimenting, I noticed how small parts of the text are rendered visible when resizing or making small changes. Basically, when librewriter is forced to refresh the editor’s screen. Sometimes small bits are made visible, but they disappear again as soon as the screen is refreshed once more.

I honestly have no idea wether it’s a hardware or software problem. All I can say is that it’s a pretty annoying thing, specially since I use the linux libertine fonts in some documents.

PS: Further tinkering seems to indicate that it IS indeed a bug introduced sometime during 5.1 and still present in 5.2. The problem doesn’t appear in

PPS: I’ve now confirmed that it is a bug introduced in 5.1.2, and earlier builds lack this particular problem.

Reading your post closely, I see you mention “wordpad” – so are you on some flavour of Windows? You need to edit into your question more information about both OS (which, version, etc.) and hardware. This looks like weird problem (of course!). I use LinLib Graphite and Gentium (Plus in my case; also Charis SIL, also graphite enabled) all without any glitches in Ubuntu (and Mint) and OSX (no MS though) with latest LibO.

@dajare: that screenshot is more or less obviously from Window$ 7 although the OS release might not be necessary to know in Window$’ case.

I don’t see that behaviour in Windows 10.

Well yes, it is indeed Windows 7. Home Premium to be precise. I’d like to mention that I also have a Win7 desktop that is unaffected by this problem.

If I were to hazard a guess, I’d say that some change in the rendering engine might have broken something on old underpowered hardware, since the laptop with the problem has a flimsy Intel 4 Express, graphics card.

But was there such a change?

Similar problem solved (Ubuntu 16.04, LibreOffice no rendering of Linux Libertine G.


  1. install LibreOffice Graphite extension (https://extensions.libreoffice.org/extensions/typography-toolbar)

  2. install Linux Libertine fonts G version, O version is not enough (http://www.numbertext.org/linux/30c468d0c27ae4784195b53f78bc6f64-LinLibertineG-20110922.zip)

It is possible, that one of the above two is sufficient;
it is possible, that you find a better source for Linux Libertine fonts (I think the above mentioned link is a specific Hungarian one).