Why Libreoffice calc 6.2 saves file size to too large?

I have a libre office calc file which has an image and few pages with database VB controls in Ubuntu 18. That all works fine no issue. The original file size was 2.8 MB until calc version 6.0. If I save the same file in calc V 6.2 the size becomes 33 MB which is too big. If I bring back to calc V 6.0 that saves only 2.8 MB. Any one can suggest what is the issue here?

It might be embedding fonts?

This solved it for me as well. I unchecked embed fonts and checked only embed fonts that are used in documents and my file went from a similarly huge size to <100k.

This a comment, not a solution. Please move it where it belongs: a comment after the question. After that, delete your “answer”.

Wow @ajlittoz the forum semantics police are out of control here. Isn’t helping people more important than playing semantics? Two helpful posts I made and I the posts are about semantics rather than helping people.

Of course this is an answer, the other “answer” was posted as a comment. I said "unchecked embed fonts and checked only embed fonts " That is the answer.

Then turn it into a formal answer: remove “this solved it fpr me as well”. Change the “I …ed” into imperative form.

Forum semantics is an important factor here: this site is not a forum and solutions needs to be clearly identified as such.

To reward you for your effort, I’ll upvote your answer as soon as it is “in shape”. Thanks.