Why LO, Base, Form, Arrange, Bring to Front doesn't work?

image description


I’m trying to have some text show on top of an image when displayed on an opened form in LibreOffice Base (6.2.2, Windows 10 Pro 64-bit). In the form’s Edit mode, I’ve overtly chosen to have each element’s layering order (Arrange) spelled out; i.e., the image, Send to Back; and the text, Bring to Front. The text elements that have all been tried to have appear on top of the image (linked, not embedded in this embedded database, Firebird), but without any luck, are Labels, Text Box, and Pattern Field.

What am I missing? or, Why is this not working?

Thank you for any reply,


May not understand your problem. You can place a text box on top of an image.

Thanks Ratslinger for a quick reply! Why do you think that layering over an image in Base can’t be done?

Sorry for that overly quick reply. As you may see, have deleted that comment. Replaced with another where I have placed text box over image. Did nothing about ‘layering’ but I am still trying to put together under what conditions this may or may not work.

@Ratslinger, I was unable to view the Pattern Field, Text Box, and Labels when the form was opened for viewing and the text was placed on top; i.e., Arrange, Bring to Front. If you were able to that, please show the result with your procedure outlined. Thanks!


Sorry for the delay but there are numerous problems with current version of Base and images. Additionally, there are numerous problems with placing text over images and there hasn’t been enough time to investigate all. In the end a bug report (file here → Bugzilla) is appropriate.

Don’t believe there is anything concerning Arrange here. To Front or Back had no effect in my testing.

Attached is a simple sample with two records in the table. There are three form each using this same table.

First form (TestBlob) is straight forward - just displays records as is.

Second form (TestBlob2) is a copy of the first form with the addition of a copied field. This is important. The comment field was copied and moved over the image. Now that wasn’t enough. The activation (Tab) order comes into play. This field must have an activation order before the image field. Sounds ridiculous but you can change the order & verify.

Third form (TestBlob3) is a copy of the first form with the addition of a newly created text field. The text field was given a default value and again the activation order was placed before the image field. Again more unusual findings. Upon first starting the form all seems OK. However going to the next record and the text seem to vanish. However, if you move the mouse over the area where the text should be, it suddenly appears! Also going to a new record there is no problem.

This is just the text field. Trying to deal with the Label field presented even more amazing findings. Field is there but text transparent.

Now all this is being done on Mint 18.3 with:

Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

and I suspect some of the problems may be due to gtk3. Will probably do more testing when time permits.

Sample ----- PictTextTest.odb

Glad to see your blobs made some difference. As I originally mentioned, I didn’t blob; rather, the images were linked. I’m new to LO and from what I have been hearing and reading, embedded images have generally been problematic.

In any event, your test illustrated another part of my experiment that I wanted to see; namely, how fields’ backgrounds end up being handled when placed on top of images; i.e., is there an alpha channel. Apparently, there is not.

@kbellis Forgot to mention a few items. Had problems whether using embedded or linked images (tried both). Needed to use embedded for sample posting here. Also, and suprisingly to me, had problems with both image types using Firebird embedded. Actually started with Firebird but the table data was consistently lost. Too frustrated to continue looking for the actual problem so switched to HSQLDB.

Based upon this testing, the current version at least (v6.2.2.2) has many problems with images & embedded DB’s.

Another note, cycling through the controls will reveal the control regardless of the activation order.

The answer to the question as to why fields don’t display on top of images remains uncertain and should be reported as a bug.

As Ratslinger has proven, text elements were displayed on top of the image the form in an Embedded database using HSQLDB Embedded, with the subject embedded image using a field type of Image [ LONGVARBINARY ]. My experiment using a linked image; i.e., not embedded, was not displayed on top of the image in an Embedded database using Firebird embedded. N.B., field type of Image [ LONGVARBINARY ] isn’t available with Firebird (LO v6.2.2.2)

Just to be clear, and as noted in my comment, embedded Firebird with linked images worked identically to the sample provided in my answer. The text field displays on top of the image when its’ activation order precedes that of the image field.