Why LO Writer doesn't save all the table properties?


since a short time ago I’m having problems with LO Writer. When I’m creating a table and I’m formatting it according to my wishes, everything looks fine on screen, as below:

However, when I save it (I usually edit file properties to embed only the fonts used in the file, or simply to embed fonts) and open it again, the table appears to have all its custom formatting properties lost and supplanted with default; only text in the table is properly formatted:

I don’t know if it’s a bug or new way of LibreOffice Writer’s working. I had no problems like that before; it started only after the update to the newest version (6.2, exactly I’ve tried some methods to solve the problem (file properties, cell protection), but the problem remained. After trying to change style to default (and not ‘table contents’), it began behaving strange, so I gave up on it.

Additionally, the LO Calc is not suffering the same issue - its table is formatted perfectly after I access a saved file.

I’d be thankful for any clue or help.


(edit: activated screenshots)

This is tdf#127036 related to “Only embed fonts that are used in documents” setting.

OK, thanks. I looked into the link you gave and unchecked the “Embed only fonts used in the document” box and left only “embed fonts in document” checked. Now the properties are saved without problem. So it can be sort of performance and export problem after all.

the comment of @mikekaganski can be made n answer and the question closed as solved?

I think the question can be closed and the comment above can be made an answer, yes.