Why "open document" will always bring me to my home folder?

I regularly work on several documents all the same folder. The “Open document” dialog will always open in my home directory, but I would expect it to open in the same folder where the currently open document is located. The latter behaviour is quite common in other programs (e.g. gedit in GNOME) and it is really useful.

This happens on Ubuntu 12.10 both with LibO 3.6 and 4.0RC1. Is there a setting to regulate this behaviour? I can’t find it in the options panel.

Try changing the Open/Save dialogs in:
Menu/Tools/Options/LibreOffice - Open/Save dialogs.

This works well. It is slightly unintuitive.

Well I’m using the Swedish version and there it’s

Menu/Tools/Options/LibreOffice - paths

And then one has to change the setting for the entry

My Documents

The down side is that now you always end up in that folder. I would like LibreOffice to remember where I were when I opened the document!

Prior to version 4.0 it seems like the open/insert file path was ‘remembered’ - which I agree is the desired method. I have also noted this with insert pictures/files in Impress so it seems that it may be an application-wide issue. I wonder if this a regression bug or done on purpose?

On XP Prof/ SP3 I tested Writer, Calc and Draw. from the portable LibO. All applications remember the directory to which the file was saved before. This even across different HDD partitions. LibO, on the same machine, also remembers pathes correctly.
Hope this helps to single out the route cause fo the problem.