why registrymodifications.xcu is not symlinkable?

I don’t understand why… I cannot symlink registrymodifications.xcu from a folder to /home/.config/etc etc.
So I have created two bash scripts to copy from and to that folder (when writer start and when close).
But it’s not the better solution.


SO: Kubuntu 18.04

@ajlittoz thank you for your answer, but I try to symlink from a my folder to my home folder, and I cannot symlink: I symlink correctly with Dolphin, but when I open LO the file in other folder is copied in home folder.

I suppose that your question does not expect answers from other users? If so, then your question looks like an enhancement request - which are offtopic here. Please file it to bug tracker. Thanks.

What do you want to do? You also omitted to mention OS and LO version. Under Fedocra 29, I can symlink and the link allows me to display (or do other nasty things) registrymodification.xcu as if it was the file itself. Remember this file is private to your user account. Consequently, in case of “cross-user” access, you need to modify permissions (and this is strongly not recommended).

To answer my question, use a comment or edit your question.

I didn’t use Dolphin nor Konqueror to symlink but a command in a terminal (Konsole): ln -s ~/.confing/libreoffice/4/user libo_user or ln -s ~/…/user/registrymodifications.xcu r.xcu. Both work perfectly.

I checked then with Dolphin and the link was created as usual. Did you set the file name in the dialog to an “incompatible” string?

What do you mean with “incompatible” string? I did everything with the mouse, not with the keyboard: I dragged the file icon from one Dolphin window to the other and I chose “link” instead of “copy” or “move”. Same result with Krusader: just libreoffice start overwrites the symlink by copying the linked file.

I used a different procedure: right-click anywhere in the destination window, choose Create New>Standard link to…. This dialog allows to select a file with an open-like file browser and to change the name of the link. If the new name contains illegal characters, like common slashes, name is rejected and command cannot complete.

I checked your procedure: works as expected here. Try to check permissions along the path.

Nothing to do! I tried them all…

I do reproduce the described problem: when I create a symlink in ~/.confing/libreoffice/4/user/registrymodifications.xcu which points to real registrymodifications.xcu in some other place, and then launch LO, the symlink is replaced with a new file. The reason is that the data is not written into the same file, but a new temporary file is created, then data is written to it, then (when write is complete) old file is removed (at this point, symlink is removed), and temp file is renamed to old name.

As I said, changing that is a topic for enhancement request.

OK, I see why symlinking worked: I didn’t launch LO, just used KWrite to have a look at it.

Thank you, Mike

Could it work, instead link the file, linking the folder the it is?, to avoid the recreation of the file broken the link.