Why won't italics display in Writer?

I just updated to the latest version of LO ( on my iMac (OS x 10.10.5) in an effort to fix an issue with page background colours. That issue is the same, but now I have a new one!

All the text I’ve made italic in my Writer documents is showing up as regular. The italics icon is highlighted, but the text looks straight. This is also true when I print the doc. I’ve tried .doc. .docx and .odt file formats: no good. The same is also true of bold and underline (strikethrough, sub- and superscript work fine though). Changing font doesn’t work unless it’s to TNR (which I hate!).

Any ideas?

you didn’t mention the font in question. I’ve had all sorts or problems with italics within liberation sans narrow. keng

I had the same problem working with Alegreya font in LibreOffice Writer ( on Windows 7. Everything went fine until I changed a line to italics. The italics were not displayed when I exported it to PDF. Your problem seems similar.

First off, you need to check if the italics style (or member) of that font family is installed. You can do this by going to Control Panel > Fonts and looking for the font. If you see multiple fonts like, in my case at least, Alegreya Regular, Alegreya Italic, Alegreya Bold, etc. then your problem might be different. But if you don’t see, then you need to download and install that particular font style (italic in you case).

Secondly, I noticed that a word in the document was styled in other font than Alegreya and that was causing the problem. I selected it and changed it to Alegreya and then exported it to PDF. That solved the problem. The PDF had the italics rendered correctly.

Please try the above solutions. They may solve your problem.