Why won't LO print?

Using Linux Mint 17.1 with Mate. Printer is Brother MFC-J430N that was working fine until I replaced the color cartridges with new Brother cartridges. Chromium and Firefox print just fine but Writer and Calc cause paper to go through the printer and it sounds like it printing but only a blank sheet comes out; now the black doesn’t work either. LO version is What can I change in LO to make it work?

I had a similar problem yesterday and found this troubleshooter recently that fixed my problem. Try this (from my post here):

In linux,

  • In Debian Cinnamon or the like from the start menu:
Click Administration | Print Settings,
Then select your stalled CUPS printer,
Click Unlock (and give it your admin password),
Click Server | Settings,
In this click the blue "Problems?" link. This opens the printing troubleshooter.
  • In Ubuntu this is:
Dash | System Settings | Printing,  
Then Server | Settings.

Hope this helps someone. Fixed it for me!

Also if this helps you please remember to click the up-arrow left of my answer, and if it answers your question, also select the check mark to the left of my answer. Thanks. Note, I’ve already given you an up-vote for your good question.

I think LO uses CUPS printing (one of 4 alternative ways to print in Linux).

A bit more: This past time it had me do a couple of things one of which was unlock the printer settings, and check Enabled. I think mine got hung because I had my WiFi printer powered down when I tried to print, or when I started up linux or something like that. But I’m not sure of that just yet.