Windows 10, 64-bit, JRE not found

I have a 64-bit computer running Windows 10. I have deinstalled Java and LO, and reinstalled both. In Explorer, Java is present: C:\Program Files\Java\jre1.8.0_261\bin . However in LO, Tools-Options-Advanced, when I use Add to target the folder, I get the error that Runtime is not found in that folder. In File Explorer, there are plenty of .dll files, and stuff, listed in the bin folder, but it shows blank in Libre.

I have followed all written instructions by LO and have watched every YouTube vid on the subject, even those in other languages, have followed all the instructions step by step… but it’s the same problem over and over again.

This is the Latest version of Java: JavaSetup8u261 (1).exe .

I am stumped and frustrated.

Did you also try to reset your user profile?
(just installed this and LibreOffice had no problem to automatically detect it (without using any Add... button)

JavaSetup8u261.exe (or any numbered variant, indicating that you downloaded it several times) is a 32-bit Web installer. So you have a very confusing description, telling about C:\Program Files\Java\jre1.8.0_261\bin (which on a 64-bit Windows OS would normally indicate a 64-bit Java) - but mention 32-bit installer, which would only install 32-bit Java. Maybe you simply changed the target path from Program Files (x86) to Program Files manually?

Additionally, you better post the data from LibreOffice’s Help->About. Could it be the other way round, when you have 64-bit Java, but 32-bit LibreOffice?

And see this FAQ.

I did reset my user profile. I deinstalled Libre and Java from Program Files and Program Files (x86). Reinstalled Java then Libre. Java went to Program Files (x86). Libre would still not find find it. I then deinstalled Libre and installed Apache Open Office. Viola! But, Apache keeps crashing when using Base… same as before.

Heh, seems like my link to FAQ got ignored… just as well as the direct link by @anon73440385.

Java went to Program Files (x86)

And this is 32-bit Java and you won’t get that working with a 64-bit LibreOffice. I provided the link to 64-bit Java and you just ignored everything already mentioned in the comments (esp. @mikekaganski’s one).

The solution ended up being:

First: Deinstalled LIbre, and deleted Java 64-bit, C:\Program Files\Java . (I deleted the Java folder in Windows.)
Then: Reinstalled Java 64-bit, Reinstalled Libre Office 7.0.0.

I went to Tool-Options-LibreOffice-Advanced, and the latest version of Java that I reinstalled was there and already selected.

I am using the LibreOffice without any JRE since (about) a year. I unchecked the “Use a Java runtime environment” option, and the LO works for me without any problem. (I am never use the Base application, I am often use the Calc and the Writer, but rare the Draw and the Impress applicartions)

(And I am often create StarBasic+API macros in the build-in API. )