Windows Install UNOCONV

I have downloaded the unoconv zip file from the dagwieeers site but there is no explanation on how to install the files on WINDOWS.

downloaded from

What libreoffice folder do these files go into?
Also none of the files have extensions. i.e. unoconv, makefile and copying. What extension do these file need?

Does the command line need to have “C:\Program Files (x86)\LibreOffice 3.5\program\soffice.exe” --unoconv. Not clear of the process, sorry for my ignorance.

Per comments by @tohuwawohu below, this is probably a bug in unoconv. As of today, the status of that bug is NEW.

The unoconv github page has an example to to call unoconv in windows:

C:\Program Files (x86)\LibreOffice 3.5\program\python.exe unoconv -f pdf some-file.odt

Since unoconv is a python script, you need to install python, too. After that, you can run unoconv using python as described above. I didn’t test it myself, but AFAIK you don’t need to put unoconv into a specific folder under the LO program directory.


Ok, let’s try it step by step.

  • Download unoconv. You can either grab the tar.bz2 archive from Dag’s page, or a ZIP file from the github site. Since WIndows doesn’t ship with an extractor for bz2 archives, i recommend to download the ZIP from github.

  • Extract the ZIP. Notice that the unoconv directory is situated in a subdirectory containing the git repository id. In my case, it’s “dagwieers-unoconv-9b68368”.

  • Open a terminal and cd to the extracted unoconv directory. I copied the complete content of the ZIP into “Program Files (x86)”. Because of that, i did:

    • Open the start menu, enter “cmd” in the search bar, execute “cmd”;

    • In the terminal window, enter (adjust the path if necessary)

      cd "\Program Files (x86)\unoconv\dagwieers-unoconv-9b68368"

    • Check if unoconv is present in the current directory: “dir unoconv”. If you get a “File not found”, check the path.

  • Test if unoconv works in general:

    • In the terminal window, enter

      "\Program Files (x86)\LibreOffice 3.6\program\python.exe" unoconv -h

    • As output, you should get a list of unoconv command line option. If this works, you’ve unoconv ready to work.

  • Still in the terminal window, and still in the unconv directory, try to execute the convert command.

In fact, you don’t really need python as a working python (for LibreOffice) ships already with LibreOffice itself. It is even recommended to use this python binary instead of the system’s default to avoid incompatibility errors. The command-line shows exactly that :slight_smile:

Thank you for the input. I have had LibreOffice installed and have been using the office suite without issues for months. Thank you for the example link… My CMD test looks the same format of the examples.

I was running.
“C:\Program Files (x86)\LibreOffice 3.6\program\soffice.exe” unoconv -f pdf c:\converttest\testcrap1.doc.

I re-installed the unoconv and put it under the python folder. Still not getting any results.

Please notice the exact path. It’s python.exe, not soffice.exe.

I tried to edit the previous comment with no luck. I also tried to delete it.
I am using “C:\Program Files (x86)\LibreOffice 3.6\program\python.exe” unoconv -f pdf c:\converttest\testcrap1.doc

But thank you for pointing that out so we don’t mess someone else up.

Some added info…The CMD command line returns Errno 21 - no such file.
C:\Program Files (x86)\LibreOffice 3.6\program\ \python-core-2.6.1: can’t open file ‘unoconv’: [Errno 2] No such file or directory

the cmd is showing double "’ slashes no space before the python-core-2.6.1

@thumper: i’ve emended my answer with a step-for-step description. The “File not found” output indicates that you’re not in the unoconv directory when executing that command. You’ll have to run the command from inside the unoconv directory.

I really appreciate your help. I just returned from Holidays and I am trying what you suggested. I did try just before leaving and got an odd error, so I waited until I returned to continue the testing.

I tried again and got the following error.

C:\Program Files (x86)\LibreOffice 3.6\dagwieers-unoconv-6094b54>"\Program Files
(x86)\LibreOffice 3.6\program\python.exe" unoconv -f pdf C:\ConvertTest\DFI.odt
Traceback (most recent call last):
File “unoconv”, line 1162, in
File “unoconv”, line 1079, in main

convertor = Convertor()

File “unoconv”, line 716, in init
unocontext = resolver.resolve(“uno:%s” % op.connection)
uno.DisposedException: Binary URP bridge disposed during call

I did a complete un-install and re-install of LibreOffice and UNOCONV, but I still received the same error. All your instructions above worked but the last step when I tried to convert a file. I did unpack the ZIP to the LibreOffice folder.

Note that I could not copy the complete error message in one comment, so pasted the error into two posts.

That new error indicates to a quite new issue that’s still unresolved. Maybe @dag can help with this?

Not sure if this issue is still pertinent, but I have been looking at probable causes and two are documented in the issue thread at

One probably cause is that the default port 2002 is in use by another process on the system. The easiest way to find out is using another (random) port that is free, eg. using option -p 12321

Another probable cause is that unoconv is not using the correct environment for the UNO python bindings to work correctly.

Hi @thumper,

Did you ever get unoconv to work properly for you on Windows? If not, please try grabbing the latest build of LO and the latest version of unoconv.

If you’re still stumped after that, consider filing a bug against unoconv directly.