Windows Share is missing in Remote Files, in Type under File Services

Under File Menu, Remote Files, Manage Services, File Service, Type, the drop down menu is missing Windows Share.

Is there something I need to do to make Windows Share show as an option? Note that I’m using the version (x64) for Windows, build e114eadc50a9ff8d8c8a0567d6da8f454beeb84f.

Image link here:

If the share has a name, eg sharename, can’t you just open \\sharename in the normal Open dialogue?

Opening isn’t the issue for me. I can open on network share using Windows File Explorer.

The issue is the inability to save to a local network share.

I believe the Remote Save, Windows Share is the solution. However, I need this option to show, as described in Using Remote Files, under the section “Connecting to a Windows share.”

Am I missing a Windows Feature, or did I not install a feature with LibreOffice? I used the recommended typical installation options when installing LibreOffice.

Inability to save? It must be possible the same way - the normal File Save dialog (without any Remote service, which is for the locations not accessible using normal system dialogs) should allow that (given that you have permissions there on the share).

The permission are correct. All applications that I use have no problems saving to this local network share. Only LibreOffice has this problem.

I am following these directions: Using Remote Files
Under the “Connecting to a Windows share” section, I’m supposed to select Windows Share. However, this is not appearing for me. How do I get Windows Share to show up under Remote Saves?

Which “this problem”? I feel like it’s an XY problem here. You are expected to not use Remote Files on Windows to access Windows shares, but use normal OS File Save dialogs, as I already told you.

The help should be amended to mention that Remote Files is only expected to have the Windows Share element when on non-Windows systems, which don’t have built-in means to communicate with these shares. This is the code that explicitly removes the Windows Share item on Windows.

Why is this getting complicated? Refer to this documentation:Using Remote Files

See section titled: " Connecting to a Windows share"

My installation of LibreOffice does not show the option “Windows Share” that is referenced in the documentation above. The question is: How do I get “Windows Share” to appear? See image link in the original post.

Sigh. Do you read what I write to you?

It is not shown on Windows. Period. The help should be corrected - but you don’t get it on Windows.

I reread your reply. So, what you’re saying is that the Documentation is incorrect. The Windows Share is NOT available if the LibreOffice installation is in Windows. If this is true, then the documentation should be amended to reflect this so people like me do not go chasing wild geese.

And that is exactly what I wrote, isn’t it?

Could you point me in the right direction for writing to network share files in LibreOffice using a Windows ecosystem? This seems to be a recognized issue, but no solution?

Sigh again. Which “recognized issue” are you talking about? You wrote that you have no problems saving to shares from other applications; how do you do that there? You likely use their Save As dialogs and navigate to the shares in those dialogs; so you do the same in LibreOffice: File|Save As, and use the same dialog.

At this point, I should start a new thread, or follow an existing thread, as you’ve answered my question for this thread.

I am sighing as well, so please stop the attitude.

I stated that I can OPEN. But I cannot SAVE. Is this difficult to understand? I will start a new thread. Please don’t post there with attitude unless you have solutions.

You can open files from a network share, so obviously not a Windows share issue. Can you just do a change to a file and save? Or does it not allow you to save a change to an existing file on a network location?

That could be an issue with your anti virus or other security software. Can you add LibreOffice or soffice.bin (C:\Program Files\LibreOffice\program\soffice.bin) to your antivirus Allow List?