Witer not displaying page numbers but the word "page numbers"

Something funny started happening, instead of showing page numbers in the footer, Writer is showing the words “page numbers”. Its happening on old documents and new alike. I save everything in .doc format (or now .docx).
Running on an iMac, osx ver 10.9.5 Build 13F34

Libre Office:
Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21

Thank you for any answers,

Sorry Alex. The page number issue appears again. I have nothing checked of the above mentioned but the problem prevails. I tried all suggested solutions but all did not work.

It seems that
Tools > Options > LibreOffice Writer > View > Display > Comments is checked.
Unchecking of Comments should show the the page number instead to the field code “page numbers”

Thank you,
That did it.
Except on mine, its Libre Office → Preferences → Libre Office Writer → View → then uncheck “Field Codes”

Have been having problem with page numbering, but this answer solved it. THANKS