Won't launch in Catalina, silently

LibreOffice will not launch on my Mac running Catalina (currently at 10.15.7). If I double-click on the app or try to launch it from the Dock, nothing happens – not even the Mac dialog that pops up when launching a non-Apple application for the first time.

  • I have installed and am working from an administrator account
  • LibreOffice does appear in the Activity Monitor but is not actually an active application (i.e., Command-Tab does not show it as a running app)
  • I cannot quit LibreOffice from the Activity Monitor, I need to Force Quit

I first noticed this with a newly installed download of 7.1.0 – but I have not used LO in a long time so it’s possible the problem was already happening with whatever previous version I had on my Mac.

I deleted the 7.1.0 app and installed 7.0.4. Same problem.

I tried running /Applications/LibreOffice.app/Contents/MacOS/soffice --safe-mode but not only does nothing happen, this time LO does not even appear in the Activity Monitor.

What’s happening, and what can I try next? TIA for any help!

Did you provide Full Disk Access to LibreOffice.app?
As a last resort you may try sudo xattr -d com.apple.quarantine /Applications/LibreOffice.app

I am not asked by my Mac to provide any particular permissions when I launch LO. So how do I provide Full Disk Access? I’d like to try that, thanks much!

@anon73440385 never mind my beginner’s Q. I found how to provide full disk access in SysPrefs. But makes no difference. Launching via the UI only adds an entry for LO in activity monitor but the app is not active. Running /Applications/LibreOffice.app/Contents/MacOS/soffice --safe-mode does nothing, not even in activity monitor. I have to Ctrl-Z out of it in Terminal.

Tried sudo xattr -d com.apple.quarantine /Applications/LibreOffice.app and I get the bouncing icon in Dock, which made me hopeful except that the app still does not launch.

Thanks much for your suggestions, though. I guess it’s back to MS Word for everything :frowning: