won't print text

Linux Manjaro OS. Canon TR4527 printer. LibreOffice will print images that I embed in a document but will not print the text of that document.

And File -> Print Preview shows the text or doesn’t it appear in preview as well?

Both image and text appear in Print Preview. Only the image prints.

And all other applications print text-only documents? Do Writer documents get printed if the document do not contain images, but text-only?

This may be an issue with the drivers I have installed for this printer. I am currently working on figuring that out. I will report back here when that is resolved.

Sorry for asking this - but could it simply be caused by an empty black ink cartridge?

Nope. I just printed a black and white image.

I have now reinstalled the Linux driver for this printer. Text and image display together in Print Preview. Text only and image only also display correctly in Print Preview. Text does not print in either case.

Text only in a text editor prints with no problem.

Could you try in LibreOffice Safe mode (Help -> Restart in Safe Mode ...), whether you see the same results? If not, your user profile may be corrupt (though it would be a very strange side effect of a corrupt user profile; but its worth a try).

Restarted in Safe Mode. Text and image display correctly in Print Preview. However, only the image prints: no text.

What does File -> Printer Settings -> Button: Properties -> Tab: Device -> Printer language type tell? Try another setting (Mine - which is an EPSON WF-4630 shows: Automatic: PDF and selecting any of the Postscript levels doesn’t work)

Can corroborate – this is happening to me with an older HP printer. Almost willing to bet that the OP also has an HP printer… Prints text fine from other applications, just not LO writer. Brand spankin’ fresh cartridges so that’s not it. Tried some custom test pages I composed with color text highlights – the highlight colors were printed with no text over top of them. Grateful for anyone who can help.

ok, sure enough, uninstalled and reinstalled all LO packages (following @anon73440385’s advice in another thread regarding inability to print to PDFs) and it fixed this issue as well

I couldn’t get a .odt document to print. Saved it as .txt, and then it would print.

This is not a solution to the question, since text files don’t have any formatting while text processing generally contains formatting (otherwise using a text processor application would be superfluous)

I just started having this same issue yesterday. In writer docs where there is only text, I get blank pages when printing. I have spreadsheets in calc that contain color and black formatting in some of the fields. The color AND black formatting prints but none of the text. For instance, I have a few fields that are highlighted in color with black borders. The color and black outline borders print - but no text in the entire document.
Print preview shows text is there. All other documents from the internet, forms saved, emails, etc print fine. Exporting the Libre odt to a pdf allows the text to print.
I was using Libre 6. when this suddenly started to occur. Upgrading to 7 didn’t help.
It is not a printer ink issue.

This is not an answer to the question.

Please do not use Add Answer if you actually don’t answer a question but commenting an answer or responding to another user’s comment. Please use add a comment for that purpose. Thanks in advance …

I had the same problem, with the addition that it didn’t print to file, either, and when using the “save as pdf” option the pictures were there but not the text. Other programs printed as usual. I couldn’t find the fix. I wonder whether it could be a memory issue (mine is an old computer, maybe libreoffice is RAM-greedy).

I tried removing and reinstalling, no change. I ended up removing it entirely, which is a bit complicated to do. Discover (Lubuntu) didn’t remove all of it. Command line removing packages seemed to forget some. I tested by typing “soffice” and the libreoffice window kept opening. Then I tried :

sudo apt remove libreoffice*
sudo apt autoremove

It did the trick, (but please be careful with such commands).

I installed openoffice4. This would be too long to explain here, you’ll find instructions online. Unfortunately, it is not just a package (there is a package but I got the error “unsigned repository - installing from such a repository is disabled by default”). But the Apache instructions are easy to follow. I launched it by typing “openoffice4” and opened the document I wanted to print. It printed perfectly.

The differences between libreoffice and openoffice4 are minimal, if you know how to use one you’ll easily use the other.

It’s not so much a fix as a work-around, but I hope it helps.

If a clean installation of OpenOffice works then resetting your user profile might have fixed the problem, LibreOffice user profile - The Document Foundation Wiki