word bracked

in MSword
image description

in libreoffice

pls check marked part, in libreoffice file. this word cut to 2 part how I manage this.

thank you

Read these guidelines and ask a good question (yours is not even a question). In particular:

  1. Tell us what the problem is actually. You may use that script every day, but, as I can guess, for the most people of the world it is exotic.
  2. Share a file. Screenshots are of little help when dealing with problems.
  3. Write in clear English. If it is a problem, use another language available at this site. Or hire a translator.

As far as I can tell, the glyphs are also rearranged in the marked word, but that may be part of the punctuation or other rules of the script (which is also unknown to me).

Word and Writer handle spacing differently, which may cause a change in line wrap. Should not break the word unless you have entered settings for automatic breaks.

An attached file is helpful. We may also need language settings and perhaps a font file for the script in order to examine it thoroughly. Please edit your question and use the paperclip tool to attach a file. (Don’t use the “add answer” pane to reply to this. That pane is meant for proposed solutions. Rather, click the Edit link attached to your question.)

What language is your document in? Your posted question is incomprehensible. I am guessing you have a language using a character set that is non-English.

Note that going back and forth between Word and Writer is liable to mess up formatting. Not in a big way unless you have multiple different page layouts in use, but flaws may occur.

To determine the exact cause, we need a file demonstrating the issue, not just pictures of it. We may also need knowledge of the script in use (punctuation rules et. al.), which I suspect that few of the regular helpers around here have. Cf. my comment to the question, above.

With those reservations, I offer a possible solution ; a couple of things which may solve the issue at hand:

Eliminate change in line break

Word and Writer handle spacing differently, so you may need to change margins and/or insert manual line breaks to have the same layout when you go from one application to the other. Note that manual line breaks is another way to mess things up, so only use that as a last resort, if you REALLY need it.

If you don’t need to edit and you need layout to be unchanged, consider exporting to pdf.

Eliminate word break

The word mangling may be the result of automatic word break. To eliminate this, switch off automatic word break in the paragraph style you have used.

  • Place the insertion point (text cursor) inside the “offending” paragraph.
  • Activate Styles in the right side panel.
  • The style in use should be marked in the list.
  • Right click the style and select Modify
  • Select the Text flow pane
  • Untick automatic word break (first item in the dialog).