Word count is off

Hey guys,

Having a problem with the word count being (WAY) off. I’m using version (x64) build 8a45595d069ef5570103caea1b71cc9d82b2aae4 on Windows 10 Pro Version 20H2 build 19042.928. I just updated to the latest version of LO and noticed my wordcount in the status bar was now off…by 40,000 words. I’m an author by trade and need to keep an eye on wordcount, so that’s a bit of an issue. Unless the system is now counting every punctuation mark as a word, something seems off. I have uninstalled and reinstalled the software and restarted my comptuer in-betwen each set to still find the problem waiting for me. When I do a manual selection with the cursor (Shift + Click) it gives me the correct word count, but not when it’s unselected. Anybody have any ideas what’s going on? I really don’t want to have to swtich to WPS writer or another alternative, as I like LO the best out of the bunch. But a 40,000 word margin of error is a bit much.

libre-writer wordcount

(retagged by ajlittoz)

You do not support? Then may I ask what the purpose of the forum is then? Or are we to gossip about boys all day? No one asked for mystical contact, the question was to the folks in the forum and if they had any ideas (or possibly: similar experiences). This is not a shared version at work, so I’m not sure where that comment came from at all. If the version isn’t stable, then why is it the latest release available on the website and not listed as “Beta”? I find your comment rater unhelpful and boarder-line snotty. If you have no solution to offer, may I suggest that in the future you save a few keystrokes?

Could you attach a short sample file with the problem so we can see if the problem occurs on our versions? In case content is private or confidential, replace it witH “lorem ipsum” (type lorem and immediately f3).

To attach, edit your question and use the paperclip tool.

While at it, retag to remove common which has a much wider scope then writer (also Calc, Impress, Draw, …). Type Enter twice to exit retag mode.

A couple of things springing to mind, that might have a bearing on word count.

  • Storage format. Writer should work reliably when documents are saved to and loaded from files using its native storage format, .odt. A common cause of various errors and undesirable bahavior is the use of the “foreign” (to Writer) storage format .docx (MS Word format)
  • Using change tracking. This should work nicely in conjunction with native storage format, but using foreign formats may throw the count off.
  • Index entries have the same potential issues in conjunction with foreign storage formats.
  • Content inside frames is not always included in word count.

In short, please read Ask/Getting Started - The Document Foundation Wiki for how this board works. It’s the first thing people should do who register here or log in for the first time. That’s especially true for professionals, so that they don’t waste their time.

@ajlittoz - I would but the problem seems to only present itself in documents with large amounts of text (ie: over 10,000). Believe me, I tried to tag it correctly only to have the page continuously reload and tell me I had to include more tags.
@ Floris - Quote: “What is the purpose of the site?—Can come together to ask and answer questions about LibreOffice.” I did ask a question about LibreOffice, did I not?

The solution (and many thanks) apparently go to Keme. I saved the docx file into an odt file and that seemed to fix the problem. While it is a pain to convert and save to a format that isn’t accepted in the (my) industry (trust me, agents/clients are hardcore about “must be in word format!”), but at least I can keep track of wordcount and covert it easily enough. Many thanks to Keme!

I saved the docx file into an odt file and that seemed to fix the problem.

Then it definitely is a bug. Unless someone takes an effort to create a reproducing document and files a big report, we would be unable to do anything with this…

@unpopularopinion: the trick to force the AskLO site engine to obey a retagging request is to hit twice Enter when it insists upon more tags. I did it for you.

Don’t forget to click on the gray checkmark on @keme’s answer so that the community knows an effective answer has been given.

@unpopularopinion, if the previous version did the job (and is still the one recommended for production work), why use the most recent one that may have other issues as well?

Whenever you see someone using a newest fresh version, and reporting a problem, it is OK to suggest to try/use an older version; but I think that it’s not OK to make it feel so as if using the newest version, people do something stupid. Remember, that the issues that might be in the most recent one don’t get fixed by miracle; and it’s such reports (when done properly, to the bug tracker, with proper repro steps) than enable to reproduce and fix them, eventually making today’s fresh version the next still one.

Big thank you to all those who do try the newest versions, even if you found that you needed to revert to an older release.

What makes you think that I’m making it feel stupid to use an older version? It has been quoted by Astur in the first comment that there is a significant difference between fresh and still. It is made clear in big font just under the version number in the download page.

User come here to get a fix first. If they want to help by reporting it in the bug tracker, fine, that’s great also. And indeed, thanks to them. Personally, I reverted to 7.0.5 for my production work but I kept the 7.1.2 on my personal machine.

But well, enough is enough. I’m tired of your attacks (supported by a few other users as showed by the votes on the comments). I’d started to give some time to the LO community, working on the wiki and helping users but I do see that I’m not welcomed. For sure, I’m more the voice of the user than the voice of the developers but well, in a Q&A site like this, more users need help than devs. I throw in the towel with the LO community, happy sailing.

We do support of course. Even if we are not a customer service but merely users like you, we do provide the best help we can.

In the LO world, it is indeed no highlighted enough IMHO that the latest builds are not the most stable. There is concept of fresh branch and still branch. Try the still one, that is 7.0.5. I’ve myself tested 7.1 and gone back to 7.0.5.

If the issue is still there in the 7.0.5 version, try to reset your LibreOffice user profile (rename it).

If still no joy, then you may have found a bug. It should be reported then.

To show the community your question has been answered, please tag the best answer (), and/or vote for any helpful answer. Else, please edit your question to add information (answers are for solutions only).

… bigger issue of MS Word Format being more widely accepted by agents/employers/customers, …

I recognise that. No problem!

On the other hand …

  • Working with non-native storage formats - in any application - means that features available to your document might not be saved to the file in a straightforward fashion.
  • With this kind of situation, translation happens with every open and every save. For features implemented differently in the two apps, workaround structures are inserted to make the result as similar as possible. Over time this builds up to a significant “residue” which may mess up content, document structure and formatting/layout.
  • MS Word claims to support the ODF storage format, of which .odt is a subset.

Best practice

  • For Writer, use .odt for work in progress.
  • If recipient insists that they will only accept .docx, save a copy of your document using the requested storage format, and submit that copy.
  • If, like me, you must use .docx for some of your work in progress (e.g. because of collaboration/proofreading workflow), use MS Word.
    It will cost some money, and you may find it less efficient for the writing process (I do), but you are going to avoid some problems that way.