Word Wrap Text in Shape doesn't work on Callouts.

I am using Draw on LibreOffice Version: Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff on Debian 10

I have enabled “Word Wrap Text in Shape” which works for all the shapes I have tried to use so far except one. It does not work for Callouts. I cannot seem to get this to work and it makes the shape virtually useless. Someone else has asked the same question for an earlier version and has gotten no answers either. Why doesn't text wrap work in callouts?

Seems to work here. Only limitation I’ve fount so far is if the text exceeds the space for the Callout. Using OpenSuse 15.2 beta

Curious. You can still wrap in Callout by selecting the graphic and in the menu clicking Format | Text then ticking the word wrap.

In LinuxMint 19 and LO if I select a graphic, right-click and select Edit Style, then in the Text tab select Wrap text it will word wrap the Circle but not the Callout. Looks like a bug to me

Cheers, Al

Nice to see that AdmFubar has it working but given they gave no steps to replicate and also are using a different version their comment is not helpful. I see no way that it is not a bug especially given Earnest Al has the same experience. I have already filed a bug report. https://bugs.documentfoundation.org/show_bug.cgi?id=133570

Works with 4.x up tp

By the way, retag your question: using singular/plural forms is useless and clutters the tag system. bug and bug-* are not meaningful, remove them. Remove text-wrap* since the option is named “word wrap” in Draw.

Callout doesn’t wrap by default in Win10 and LO6.4.4.2 too. Here is a quicker work around than Format >> Text. Once word wrap is set as default for new graphics, whenever you do a callout just double click on Default (at the top) in the Styles and Formatting sidebar and the text will wrap. I can’t update the style for new callouts though, it says wrap is on but it doesn’t

Draw also offers a style feature which is more limited than Writer but you could use it.

By default, all shapes and objects are styled Default (how surprising!). But you can style them otherwise by selecting an object and double-clicking on a style name in the side style pane.

Define a new style (or modify an existing one) with all the attributes you like, including the Word wrap text in shape.

Draw and annotate your callout without caring for anything. When done (or before typing), style it with a double-click. Quick, neat and efficient.

Bonus: if you want to change the colour of all your callouts, modify the style, it will apply instantly to all of them. Don’t hesitate to create specific styles to address specific sets of shapes.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

I tried this and it did not work. However, it did lead me to something that did. I will make an answer which details the process. Thank you.

P.S. I used the tags that I did because they were suggested. While I agree that it “clutters” the tag system in practice those tags already exist. The purpose of including them was so that my question would be included under any of those already existing tags. If we can get all the other users who used tags with minor differences to consolidate their tags to only one then it would be effective. Otherwise I will leave it be. Also, the likely reason “text-wrap” exists as a tag is because that is what it is called in Microsoft Office. Until such time that both programs use the same terminology for the same feature it would be prudent to include both tags for people who may be coming from MS Office and not yet know the LO terminology. Thank you for your input but I will be leaving the tags as they are.

Going off of ajlittoz’s answer I was able to find steps to remedy this issue (at least until the bug is fixed).

  1. Create your callout and have it selected.
  2. From the styles menu on the right side create a new style. (left click the A with a paint brush icon and right click opening a menu where you can select the “New Syle” option.)
  3. With the callout still selected double click the new style to apply it to the callout.
  4. Edit your new style left clicking the new callout with the new style and selecting “Edit Style”.
  5. From the Text tab in the style editor window unselect “Resize shape to fit text”
  6. From the Text tab in the style editor window select “Word wrap text in shape”
  7. Press Ok to save changes.

Text will now wrap in the callout. You can also reselect the “Resize shape to fit text” option if you want and wrapping will still work. Note that this only works for a custom style. Replicating the same steps with the default style does not work.

Edit for clarity: ajlittoz informs me that his style icon is not an A with a paint brush but rather a T above a triangle. Others may have yet something else. The styles icon should be the third down under the gear. I have included a picture of my own for reference.

image description

Obviously since I made the answer having solved the issue myself this should be the accepted answer. However, the site informs me I don’t have enough points to do that. Due to a broken point system this question will remain unanswered.

Step 2: where is the “A with a paint brush”? When the styles list is selected (3rd vertical icon at extreme right, looking like a T above a tiangle in my default theme), I have a list of style names, no icon.

Customising a built-in style, including Default works equally well for me.

@guywhotypeslow: this is not a “broken point system” but a self protection. Since this morning, there is again a spam campaign against AskLO. I already deleted between 5 and 10 spams. Imagine what a spammer could do if he were entitled full capability as soon as he signs up.

Please recheck your procedure. It is not as clear as you think and may be wrong in some aspects.

Thank you for your input ajlittoz. However, telling people who are experiencing an issue that you are not having that same issue is not helpful and only serves to make a frustrating situation even more so. You seem to be implying that it is not a real issue and is only user error. Others have already confirmed they have the same issue so that is clearly not the case.

@guywhotypeslow: thanks for the clarification; we’re talking about the same thing in the end. However you can nevertheless modify an existing built-in style. They don’t represent absolute truth and can be customised by the user. Only, you can’t delete them otherwise LO could crash.

@ajittoz, fair enough about spammers. The issue remains that it will remain unanswered until such time that I have 20 points, which is likely not to happen. My answer is as clear as I can make it and I have already spent hours of my time on this. Feel free to make your own that is even more clear if you can. I would say my answer was clearer than the one you gave so I am not sure what your problem is.

@guywhotypeslow: I don’t imply this is a user error. Draw development is not on par with Writer or Calc. Its ergonomics could be largely improved. Built-in defaults may not be well-chosen and IMHO do not fit any user requirement (only one example: default text size is much too large for the majority of cases and too small for titling). The styling system itself is not really convenient and discourages many. I think Draw becomes really useful only after you have defined your default templates with all customisation made in styles.

The issue you experience is neither a bug (Draw does not crash) nor a user error (Draw does exactly what the user told byt user did not know what Draw would do) but clearly a lack of knowledge of user experience to be fed back into the ergonomics, a lack of easy documentation on the defaults and a could-be-improved style system.

My best recommendation is to configure Draw to one’s liking and store this in a template.