Write 7.1.1: How to set internal cross-references with "go to page" hyperlinks as automatically done for a Table of content on an exported pdf?

Dear all,

As from the title, I’d like to be able to be redirected when I click in any cross-referenced link inside a pdf document (e.g. citations, figures, chapters) as in such documents (created with LaTex). Somewhere in LO forum, I have seen it is not possible but when a Table of Content is set. Is there any trick to do, eventually as a setting and not manually for each link?

OS: ubuntu 20.4
LO: 7.1.1 stable
citation extension: Zotero

EDIT: I have posted the same question at the Zotero forum and apparently there is no such option from the Zotero extension side. They suggest tu code a macro to do so!

EDIT2: .odt and its .pdf export as examples NOTE: the link redirects to a download from an external website.

Links within LibreOffice are exported to pdf as links, so footnotes, links to figures, links to other chapters will all be live in an exported pdf. No macro needed.

The Writer Guide has some good explanations of cross references and how to use them. Cheers, Alistair

The problem is exactly that cross-reference to figures and bibliography are NOT live on a pdf. It is the case even in the official guides you are suggesting: a cross-reference such as “see chapter xx” is NOT active. Just the TOC has such behaviour. In LaTex, it is possible to tune this internal reference capability, as shown perhaps here

The cross-references will be exported as PDF targets provided you request them when exporting.

In dialog for File>Export As>Export as PDF, go to Links tab and enable Convert document references to PDF targets.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

I have done it, but just the TOC has the right behaviour. Cross-reference to chapters/figures/bibliography along the text remain plain text. Could it be linked in the way I defined my cross-references? Should I perhaps add a bookmark or modify some options in the cross-reference menu?

Bookmarks and cross-references are essentially the same thing. It won’t make any difference.

Attach a sample file for inspection. You can attach only to a question, so edit yours and use the “paperclip” tool.

While creating the example file, I figured out that to show the expected behaviour I need to cross-reference with “Text->Reference”. Nevertheless, I upload both the .odt and the .pdf because the link to the bibliography created from Zotero is not working as intended.

It won’t work. Blame Zotero.

From what I see, Zotero doesn’t follow Writer coding principles but adds its own stuff which is managed by macros (I have not installed Zotero and I can’t have a look at these macros). This is probably due to the fact that Zotero is application-agnostic, being available on many office suites.

My analysis shows it adopted a word-like approach, using Word primitives (like Word sections), instead of trying to be adapted to the active application.

Bibliography entries are put in sections (this is not necessary in Writer) and the entry is not “decorated” with bookmarks/references as it should. It is “simple” text with direct formatting (à la Word)! This means no marker is defined in the entry, therefore the entry cannot be the target of any hyperlink.

Referencing insertions like [1] are not fields in Writer concept but some stuff managed by the macros.

Either give up using Zotero for Writer bibliography or live with no bibliography links in PDF.