Writer (6.3) adding macros to old document when opened?

I have only noticed this since installing version (x64) on windows 10 (Home, v1903) over the weekend (upgrading from 6.2.5).

Symptoms: When I open an ‘old’ (i.e. last saved before I upgraded to 6.3) Word .doc document in Writer, I am getting a popup telling me that macros are disabled, but that the document contains macros. Actually, the document does not contain any macros, and I can check that by opening the same document in Word.

A couple of months ago, I was trying out a macro on a Calc spreadsheet (first and so far only time). Until last week, I didn’t have any problems opening .doc documents in Writer, but since installing version 6.3, every time I open one, I get the popup described above. At first, I thought it was only on documents I had edited recently, but yesterday I opened one I haven’t opened for at least a couple of years, and that gave the same warning.

I have removed the macro (it was in the My Macros - Standard module), and created a new template which as far as I can tell doesn’t contain the macro, and new documents (saved as .doc) are fine, but old ones still come up with the warning.

I found instructions on how to ‘remove’ the macro by saving the document as .fodt and then using a text editor to remove the relevant lines, and that appears to work, but I don’t really want to have to do this to every document.

Is this a bug? A feature? Does anyone have any idea if there’s some setting I can change to correct the behaviour?



Existing .docx documents are fine.
Also, I have found that I can save the problem documents as a different format (I’ve tried .docx and .odt), close the document, open the new file and save it in the original (.doc) format, then open the resulting file, and it’s fine again. (But I still don’t want to do this to every document.)

I doubt that LibreOffice adds macros to documents where they weren’t present; it’s possible that newer version started to detect something pre-existing in the document as “macro”. It would help if you file a bug report and send there a sample document which didn’t trigger that warning in a previous version, but started to trigger it now. Please then post a link to the bug here for the reference. Thanks!

Thanks Mike, I’ll do that when I’m able.
I agree it’s probably it’s detecting something that it didn’t before - but I don’t think it’s in the documents themselves. The only time I have even looked at macros in LibreOffice was a couple of months ago, when I was trying one out in Calc. Last night I tried opening a .doc file that hadn’t been amended since 2006 (and definitely didn’t have any macros), and it still came up with the same message.

It must be something in the document, since you yourself mentioned that saving it in a different format then back as DOC solves the problem. Yet, it isn’t necessarily a macro, it could be a false detection when something unrelated is detected as a macro, which is why it’s important to have a proper report.

Thanks Mike, that makes sense.

Largely irrelevant now, as it seems to have been fixed in, but just to complete the things I tried, I created a brand new document in Microsoft Word (I have version 2003), opened it in Writer ( and got the macro warning. I also tried it on documents I haven’t changed since 1999 - same problem, but on older Word documents (which Word 2003 won’t even open) there was no warning.

I’m using and have the same issue with Macro warning. To be totally honest, I don’t know how to make a macro. My documents are nothing more than simple Microsoft Office Word docs with a few simple paragraphs in them.

Edit: my program wasn’t showing me that there was a 6.3.2 update. When I manually checked for updates it saw it, which I updated it to. 6.3.2 did indeed solve this problem thankfully. It was driving me nuts!!!

I was logging a bug report, when I noticed that 6.3.2 (release) was given as an option for the problem version. So I have installed that - and it seems to have been fixed already.

Thanks all.