Writer 7.2. Master Document Pages Ignore Page Numbering Restart Styles

I have a tiny demonstration of my problem which can be downloaded from my ProtonDrive share: [testPageNums Directory Zip]

I created a template which I used to create documents. It is the Template.TestPageNumbering.odt file which was used to create the TestPageNumbering.ott template.

The template has the following relevant styles:
Page Styles:
Title Page – unnumbered pages
Roman First Page – roman style page numbers
Roman Page Numbers – roman style page numbers
Arabic First Page – arabic style page numbers
Arabic Page Numbers – arabic style page numbers
Paragraph Styles:
Title – assigned to Title Page page style
A1 (Heading 1) – assigned to the Arabic First Page page style
An (Heading 1) – assigned to the Arabic Page Numbers page style
R1 (Heading 1) – assigned to the Roman First Page page style
Rn (Heading 1) – assigned to the Roman Page Numbers page style

The master document I created contains 5 files, in the order:
TitlePage.odt – a title page using the Title para style
R1.odt – a doc page which begins with the R1 para style
R2.odt – a doc page which begins with the Rn para style
A1.odt – a doc page which begins with the A1 para style
A2.odt – a doc page which begins with the An para style

The master document has the template styles loaded, then master was updated.

Here is a summary of my results:

Expected                               || Actual
Unnumbered Title Page                  || Page 1
Roman Numbered Pages, starting with 1  || Page 2
Arabic Numbered Pages, starting with 1 || Last Roman Page + 1

So, the bottom line is that all page numbering restarts are being ignored.
In addition to the above, I have tried a bunch of other stuff, such as inserting “null documents” (which use the default page style and only contain a page break assigned to the default page style) after the TitlePage.odt file and after the R2.odt file. Nothing seems to work!

I have read, reread, and reread some more the Writer 7.2 Guide. I have read dozens of posts on master document page numbering from others both here and on other blogs. I can’t figure out what I am doing wrong.

What have I missed in all my research???

Help GREATLY appreciated!!!

And, yes, my zip file is safe. I promise!

Tech Details:
macOS 10.14.6 (18G9323) fully patched
Version: / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

(edited by ajlittoz to make the Expected/Actual block more readable)

This may be the only time when you need to apply direct formatting.

On every page where you want to reset the page numbering to 1, put the cursor in the first paragraph on that page (not in a frame), select Format - Paragraph, Text flow tab, then tick Insert, select Page, tick With page style, select the page style, and tick Page number, enter the number.

@floris_v ,


That was EXACTLY the problem. For some reason, both first paragraphs had the “page number” box unchecked. I think I looked everywhere except the exact paragraph using the formatting.

That problem needs to be documented somewhere in the Writers manual! I bet I’ve spent the better part of two days trying to track down what I was doing wrong.

Thanks again,

Jon Kibler