Writer 7.6 Disable Alt Key

In Writer, I always use the Alt key with the Numpad for special character shortcuts.
Since I downloaded 7.6, Alt + 1 to 7 opens different lateral menus (Properties, Styles…), preventing me from peacefully using my shortcuts.

In the Keyboard Shortcuts menu, only Alt + 5 to 7 appear and can be removed. The others are not referenced so I cannot remove them.

What is the solution?

1 Like

Don’t forget keyboard shortcuts can be defined in 2 “levels”: specific component (Writer, Calc, …) and global (valid over all the components).

In my under Fedora 39 (Linux), Alt+ 14 are defined in the global level (labelled as LibreOffice radio button) and Alt+ 57 only for Writer (the other radio button).

Definitions in the global level are overridden by definitions in the component level. Of course, if you define none, you must delete those in the global level.

PS: when asking here, always mention OS name, LO version (full with the 4 numbers) and save format when question is about a document.

1 Like

More precisely three levels: document, specific component and global. :slightly_smiling_face:

Ok, I use Windows 11 with LibreOffice
Yes I can see these Alt+ 14 shortcuts are working in Calc too.
Do you know how to delete these global shortcuts?

The simplest way is to override them by one of your user shortcuts for Writer. If you have no user shortcut at this position, just select it and press Delete.

By the way, are you looking at Tools>Customize, Keyboard tab?

Thanks for your reply. No, as I said, only Alt+ 57 are referenced under Tools>Customize, Keyboard. Alt+ 14 are not, maybe because they are global level shortcuts as you say, and I have no idea where to delete them… Do you have an idea?

I use Alt with numbers to insert special characters, these Alt codes are standard in Windows. I do not want Alt to be assigned to anything else.

As I have already mentioned, there are 2 radio buttons at top left of this dialog. One is labelled LibreOffice which gives you access to the global settings.

To insert Unicode keypoints, you have another LO method (different from the OS one):

  • type “U+<hexa_encoding>” (without the quotes, U or u are equivalent) where hexa_encoding is the hexadecimal code (this is different from Window$ where you type decimal) of the desired glyph.
    If there is no ambiguity with preceding text, you can omit “U+”.
  • press Alt+X

This method avoids the pitfall of pre-defined keyboard shortcuts.

1 Like

I had never noticed that radio button. Thanks a lot!