Writer Bad Allocation Failure

Yesterday and today, I encountered a weird crash in LibreOffice Writer (version I’ll be typing along and without warning, a window pops up saying something about “Fatal Error: Bad Allocation.” A split second later, LibreOffice shuts down, closing my files. When I double-click a file to reopen it, the recovery dialogue begins, but it always says that particular document can’t be recovered. It will open it, but any changes I’d made since last saving are gone, regardless of whether it auto-saved or not. Needless to say, this is getting extremely frustrating!

After this first happened yesterday, I tried upgrading to the newest version of LibreOffice, but every time I tried, the installation failed. It said a certain file or files were corrupt and the install had to be aborted. I tried twice, but to no avail. When I canceled the installation, I found that it had deleted my old version of LibreOffice, so I had to reinstall it. Fortunately, it installed without issue.

I didn’t have any more crashes after that, so I thought the problem was fixed. But then today, it happened again. Working on a file . . . clicked Save . . . and boom! Halfway through the save, it pops up with the Bad Allocation error and the whole thing shuts down. I lost everything I’d typed in the last five minutes, which was aggravating.

Any idea what’s causing this fatal error? And more importantly, how to prevent it?


The original post by L_Vidler is a year old but I am encountering the same problem but mine occurs when selecting fonts in Writer. I am on Win 7 and using LibreOfficePortable_5.3.3_MultilingualStandard.

I do have a fair few fonts installed and it could be that one of them is causing the problem to occur.

The message that comes up when recovering the document says:

“Due to an unexpected error LibreOffice crashed. All the files you were working on will now be saved. The next time LibreOffice is launched your flies will be revovered automatically.” And then lists the file to be revovered.

The subsequent recovery / crash reporting pop-ups are really confusing but I finally was able to recover the document after saving it to a new location with the file new name allocated to it by the recovery process.

Would appreciated any help and assistance in resolving this problem as reinstalling LibreOfficePortable has not helped.

Thank you.

Oops, new to the forum, the above should have been entered as a comment.