Writer, calc: font and font size styles are not applied to Thai script

Hi!

I’m unable to change font and font size using styles on Thai script in Writer and Calc.

Other attributes (eg font color, indentation, line spacing) are properly applied.

I can change font and font size of Thai writing with direct formatting, but not with styles.

When I apply a style to Roman and Thai writing, and then change font, font size and font color of that style, the Roman text will reflect all the changes. The Thai text however, will only change the color, not the font or font size.

Any suggestions on how to fix this?

Thanks!

LO 7.0.6.2 downloaded from the official website on Linux Mint 19.3 Mate

Answering for Writer only.

Thai is considered a “complex” language and this specific handling needs to be enabled in Tools>Options, Language Settings>Languages. You must first activate the CTL menu by ticking its checkbox. Next you select Thai from the CTL menu.

This changes slightly paragraph style configuration. Unicode coverage becomes split into “segments”: one for “simple” scripts, one for CTL scripts with separate font selection. In the Font tab, you set separately font properties for Western text and CTL.

If you didn’t enable “complex” script management, paragraph style modifications will apply only to Western scripts.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

(answer updated to match the dialog labels in 7.1.4.2)

1 Like

thank you very much!