Writer can't open documments from Mapped drives

image description Hello, whenever I try to open a document in a mapped drive in Windows 10, I only get this window in response, however it works fine in the One Drive virtual cloud, anyone knows why this behavior?

The only thing which can be said by now (using thousands of documents on mapped drive myself):

  • Everything in that area depends on the details of the connection (which you do not provide)
  • Some “modern” solutions in fact implement synchronization and are not based on mapped drives (e.g. One Drive)
  • Some servers don’t allow creation of hidden files (filename starting with a . [dot]), which are essential for LibreOffice lock files.

You need to set your local network as a private network.

You also need to mount the drive by opening it the file manager, Windows Explorer. You can also do this by clicking File - Open and navigating to the file. They are supposed to get mounted on booting the computer but Wi-Fi networks take too long to verify, so the computer boots without mounting the mapped drives.

Network set to private, Its mounted but it doesn’t open with Writer, I can access all other files with other software, I used to be able to edit them without issues except that it would sometimes disconnect and ask me to mount it again. Don’t know if Microsoft changed something in One Drive since then.

to mount it again … changed something in One Drive

This sounds incomprehensible and contradictory to me: OneDrive is not a solution based on mounting a remote filesystem but a synchronization solution. There is no mount of a remote filesystem but a process watching files (by default) in user’s OneDrive directory and syncing those files to a remote storage (and hence you could have trouble accessing a file from other systems, if you shut down the originating system of a file before the file is completely synced).

In other words:

If you need to mount a drive you don’t use OneDrive –or
If you use OneDrive you don’t need to map/mount a drive/remote storage device.

The error image is not from a missing mapped drive on a local network; it refers to an Internet connection and a server.

Its “my.sharepoint.com@SSL\personal” (server?). I used One Drive before but mapping was more convenient until now.

It looks as if you need to add your sharepoint location as a trusted web location. From Mapping and syncing network drives that connect to sharepoint , on Microsoft site

Possibly File > Save Remote might be designed for this

Followed all the instructions still get the same error.

It looks like a SharePoint configuration issue. The OS manages file access, not LibreOffice. Best to ask at Microsoft forum

I don’t know I can open the file with MSWord and even the file previewer can open it and show me its contests. [link text](http://C:\Users\USER\Pictures\Screenshots\Screenshot (182).png)

Try this blog by Mike Kaganski: 1st part , 2nd part

There is still the Save Remote option.