Writer document export to PDF works wrong on formulas in dark theme


I’ve been having troubles with LibreOffice Writer lately.
I have the LibreOffice version (x86_64) in dark theme on a laptop on Windows 10.

When importing to PDF, formulas are all in white on a white background, while the text is correctly put in black. I was wondering is anyone had this problem before, and if someone had a solution to it?

Thanks yall for the potential help :slight_smile:

As suggested, I’m gonna add some explanations.
If it wasn’t clear before, I’d like to state that the problem of display of the formulas isn’t on LibreOffice itself, but on the PDF after the document was exported. It appear to be more of an encoding problem (maybe?) rather than just a display one.
The problem is that I don’t know the architecture of LibreOffice that well, and if someone appear to know wich parameter I should change, or an eventual solution do not be afraid to answer below while I continue trying things

Does the same problem happen with a non-dark theme?

It does, I found the solution which I’ve put in the answer to my own question. The problem wasn’t the dark theme itself, but a personalisation tool to get a black background on the page that I need to disable.

To explain everything, I have to disable this tool, then update every formula by double clicking on them (as if I wanted to edit them) before exporting to pdf.

I may try to develop an addon to make the conversion of formulas automatic.

That is just a display issue. It does not work wrong on the formula, in other words, it will not affect the document itself. You do not expect your inserted graphics to be inverted? This is also why formula’s, which technically appear as a graphic in the document, are not inverted.

The problem is that in LibreOffice formulas are perfectly right displayed (white in dark mode) but on the pdf which got a white background, thoses formulas stays white. So even if it’s in the category of “display issue”, it is something that doesn’t go away when trying to read the pdf on other devices. Maybe more of an encoding problem?
It’s interresting the fact that it is considered by the document as a graphic, a thing I didn’t know, but do you have an idea of how to make libreoffice convert those graphical . maybe a certain parameter in the libreoffice files? Sadly I don’t know much on the architecture of LibreOffice itself…
Thanks for the answer also :slight_smile:

Your question is not quite as clear. So I advise you to edit your question to clarify: add all relevant information there. it will increase the chance to attract a valid on-spot answer. Not everybody reads through all the comments in order to gather all information.

1 Like

Ok, I tried to explain my problem as clear as I could by adding explanations. Thanks for your time

I am gonna answer to my own question because I found the solution for anyone wondering after me.

I had in my Interface Colors (in Tools>Option>Interface Colors) set as “LibreOffice Dark” to get a black background on my page.

Before exporting a pdf document, if I set these Interface Colors as “LibreOffice”, and then double click on the formulas as if I wanted to edit them, I will have those formulas in black in my pdf document.

I think it is because of the graphic nature of the formulas, which seems to not be updated automatically.

I may try to develop an addon to resolve this problem if I don’t find anything like that online.

Thanks yall have a great day

If that is the case, then report a bug. An interface setting should not have effect on the printed or renderered (to PDF) text.