Writer doesn't autoformat internet urls

How can I make Writer to autoformat internet urls?
Thanks in advance!

@sete: Check your offline help for url or URL -


Turning off Automatic URL Recognition is linked to

entire article… which explains turn on /turn off


Tools -> AutoCorrect -> AutoCorrect Options -> Tab: Options -> Option: [x] [x] URL Recognition

This is the default. If it doesn’t work for you, you may give resetting your LibreOffice user profile a try.

Hope that helps.

After resetting my profile everything is right again.
When I type a URL, it changes automatically his format.
Now it’s underlined and then it’s a link to the site typed.