Writer doesn't recognise some characters in DDE links

I linked some data between Calc and writer ( for windows).

Everything works fine except some characters. Some of them are shown in writer as question marks.

For example:

15٫2 is displayed as 15?2 , but the same sign is displayed correctly elswhere (0,17x0,7 is shown correctly in Writer)

Hi eli

I suspect a disjunction between the locale of the linked-data & locale of LO. To try to example this:-

:~$ locale

So, for me, “15,2” should be displayed “15.2” in my locale. Hence my opening sentence but, unfortunately, I cannot perform a test as I do not have access to Windows.

Added later:
It will take you a lot of searching to understand this, but I will attempt to give an overview. First, let me say that I am successfully editing a large file originally constructed with OO under WinXP; it has a very great range of characters (including rtl chars) & has given zero problems editing with LO under Debian.

There are 2 features in (Linux) locale “$LANG”, and these are different to each other:

  1. language: (“en_GB” == UK English)
  2. charset: (“UTF-8” == utf8 variant of Unicode)

The first is ultimately (but not directly) responsible for the change from “15,2” to “15.2”. Each locale has it’s own variant for number separator, date pattern, quotation character, etc., although it is perfectly possible to speak French but prefer Hungarian locale patterning (whatever).

The second has zero connection to the first, but is ultimately responsible for your update in the disjunction between char display. The most likely reason is that the source file was produced under–and contains within–a Windows code-page charset. All modern OS use Unicode as their charset, and the nonsense that you are experiencing has thus gone away.

Thus, the classic Windows code-page is Windows-1252 (also called CP-1252) which is Latin-1. Your char ‘Ø’ is within the “Latin-1 Supplement” and, yes indeed, was included within win-1252 (it was NOT within the original 7-bit code-pages but WAS within the 8-bit CP introduced at win98). The chars within the hi-bit range of each code-page are the precise chars that tend to differ between each code-page. ‘Ø’ == U+00D8; ‘ø’ == U+00F8. Hi-bit chars start at 7F.

Fixing your problem is difficult, although not impossible - it depends just how important this document is. First you need to discover the reason for the disjuncture. If indeed the problem is due to mis-matched CP then you need to translate between the two. I do not know of any pre-made tranlators, but it is possible. If you have the skill & time it will be possible to write your own.

Where do I need to put this “:~$ locale”?

On the other hand, I tried to open the same file in ubuntu. It doesn’t recognise some other characters, like the “Ø”.

What you quoted is an example from me of of how to discover your computer’s locale under Linux (in a console). Windows does things differently, and it also depends which version. The example that you gave of Ubuntu + the “Ø” char suggests that the source file has been constructed under a Windows that is XP or earlier (almost certainly 8-bits, using code-pages) whilst your Ubuntu is likely to be utf8 (as my example, which was under Debian). I shall add extra to my original reply.

First, I am sorry for the delay of my comment, and thank you for your detailed answer.

As for my system, it is windows 7 (arabic - rtl). I tried to change language settings in control panel and also in libreoffice (decimal separator). I managed to get improvements in the display of the “Ø” and even the decimal separator: no “?” are displayed.

On the other hand, i put my files in ubuntu (english), but this time I did a new dde link within ubuntu and it worked perfectly, even better than window

Glad you got it sorted. If you are satisfied with the reply then please tick the answer (:heavy_check_mark:).