Writer erases every 0 beginning a number. How to stop this?

In every table, every number beginning by a 0 is changed, and the 0 is erased. For instance O23 becomes 23. I need to stop this, but I just cannot find how to do. Please help.

I have a “Tool” menu (in French “Outils”) but there is no “Option” under it. See screen capture.

image description

See the comment in my answer - you did not mention that you are using macOS (Move to LibreOffice -> Preferences ...)


most probably you have set Tools -> Options -> LibreOffice Writer -> Table -> Section: Input in Tables -> [x] Number recognition
Uncheck the option and it won’t happen again.

Tested using LibreOffice:

Version:, Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US, Calc: threaded

[Update - based on OP’s comment and additional details]

Please see the following screenshots (for macOS):



Hope that helps.

If the answer helped to solve your problem, please click the check mark (:heavy_check_mark:) next to the answer.

Thank you for answering. However I use LO Version: in French and there is a “Tool” (Outils) but no Tool > Option at all. So it doesn’t help. But I’ll try to download a 6.4 and see what happens. So thank you.

You seem to be on macOS (which you did not mention) and then the starting point is somewhere in LibreOffice -> Preferences -> LibreOffice Writer -> ... on the left side of the menu bar. Updating won’t change that …

Sorry for forgetting to mention that. I found the “number recognition” and strangely the change was effective in one table but not in another one (in the same file). Moreover I found a “Number recognition” also in the Table menu, but checking or unchecking it doesn’t see to change anything to my problem.

The problem is: If a number recognition once took place the cell got a number format assigned. You need to reset the format to text (format code @ using Table -> Number Format)

More bizarre : some lines keep my 0 in the beginning of numbers and other do not… So I just had to “add a line under” and they had the same property. It’s OK for this table, but it remains a mystery to me.

YES !!! this time I got it. Thank you very much.