Writer Freezes - suspect hardpage returns, corrupted code

I have a three hundred thousand word document I have been working on for several years (a work in progress).

System is fresh install Fedora 21/64 (just upgraded from Fedora 20/64 - problem was occurring on Fedora 20 as well) 8 gig of ram, 2 x SSD’s.

When I try to work on it it freezes. Freezing the entire computer system (Fedora 21/64, 8 gig ram 2xSSD’s etc.) I don’t believe it is insufficient resources.

I believe it is corrupted code as the document also has trouble opening in Calligra Word and Abiword. Other documents open just fine. In fact, other Libre word documents seem to open okay.

The document has ended up with manual hard page returns that I am unable to delete. I have tried the 'selecting the paragraph with/after/before the hard page return, Format - Paragraph - Breaks, tick/untick box. But to no avail. The hard page breaks persist.

I have tried: Format - Clear Direct formatting, and it dropped the document size from 870kb down to 655kb, and sort of seemed to help, but freezes and soffice.bin 100% cpu max still occur with LibreOffice becoming unusable.

I’m at wits end here but think the freezes and very poor performance are occurring due to the hard page returns that have some how inadvertently been inserted. I want to get rid of them. But CANT! I am thinking I must go into the code / raw xml to delete them somehow.

Please help. I have spent days trying to fix this, and re-installed my entire operating system.

Hard break between two pages.
In the Print Layout View (View Menu) you should see a hard break line between two pages. (You did not mention this line in your question.)

In my case this line is kind of read so I see it easily.
Clicking on thie line opens a small roll down menu

image description

Rolling down the menu and you see the possibility to delete the hard break

image description

This could possibly solve the hard break problem, If not, there must be something corrupt in your file. Maybe you could upload a part of your file containing the hard break and maybe some of the real brains in the forums can open the file and identify a solution. (Be careful about the text; this is a public forum!)

Is it only with this very file with the hard break problem?

If no, I would reset my user profile. For details please refer to: https://wiki.documentfoundation.org/UserProfile

Should the problem be related to your Fedora OS I am not the expert for this. Sorry.

You say that it is a word document. You do not tell us if you tried to save it in .ODT format. That would solve the problem might be?

You could try copying and pasting your document into notepad which will remove all the formatting. You can then copy and paste it back into a blank LO document or even a Fedora document if that would work.

If this helps then please tick the answer (:heavy_check_mark:)
…and/or show you like it with an uptick (∧)