Writer freezing

I’m using the latest stable version of LibreOffice with Ubuntu 16.04.

I have a lengthy document that I’ve worked on for months.

This morning, when I tried to save edits to it, Writer froze.

First, I reset my profile. No help.

Then I purged the existing version of LibreOffice and resinstalled it from scratch.

The same thing still happens when I try to save edits. Furthermore, after I force the app to quit, I can’t re-open it. I have to shut down the computer and boot up again. I then open the document, try to save an edit again and the app freezes.

What else should I try after having recreated a profile and re-installing from scratch?



What is your notion of latest stable version of LibreOffice (asking since the phrase latest is not unambiguous)?. An which format is your file (.odt or some foreign format like .doc/.docx)?

Apologies for the slow reply. I am using version, which I obtained from the LO site, not from Ubuntu. My document is saved in .doc format.

The edits I was trying to save were in one lengthy footnote.

I thought I might solve the problem by deleting the footnote and adding it back again from scratch. I began retyping the footnote, saving as I went along. It kept saving properly until I got to the very end of the footnote. Then, when I tried to save, I had the same problem.

I wondered whether the problem could be related to some memory setting in LO. I found a post suggesting how one could increase various memory settings and what one should increase them to, but when I looked at my memory settings, all of the values were already higher than those the poster suggested increasing them to.

This problem is making me very panicky. I use writer for all my word processing.

Maybe I should add that when I openwriter and then run the command “ps aux | grep writer”, I see that the writer process has this added at the end: “splashpipe=5”. I don’t know what that means; can it have anything to do with my problem? What would changing that value do?