Writer - Grammar checking?

AFAIK neither 6.3 or 7.0 (alpha) does grammar checking. I saw the reference to After the Deadline. I installed it and… deader than Julius Caesar. Even the on the on-line demo was dead. I typed in a sample with double negatives, misspelled words, and other sins that should have AtD screaming. Nada… “no errors found”. I got the same result with v6.3 and 7.0 alpha.

Either I did the installation incorrectly (yes, I restarted LO) or AtD is no longer working.

What are my choices for grammar checking?

Edit your question to mention your OS.

Under Windows, the installer contains a grammar checker (I don’t remember which and don’t know about its reliability). Under other OS’es, grammar checkers, if any, must be manually installed. Check the extensions site.

Read these guidelines and ask a good question.

In particular: what is the language that you are trying to check. What exactly makes you think that the grammar is not checked? You say,

I typed in a sample

Well, give us the sample.

Also, with bullshit like

deader than Julius Caesar.

you’d better go to some social media site. This one is for discussing LibreOffice usage problems, not the history of the Roman empire.

I think OP is saying that dead is an absolute, so “deader than Julius Caesar” is grammatically wrong.

It sounds like an install failure or communications error with AtD server. I can’t help with that

The Windows version of LO comes with Lightproof grammar checker, other OS need to install separately. In my Mint Linux 19.3, there is an option to install Lightproof but because I have installed a Flatpack version it doesn’t seem to work with it; some sort of version incompatibility I expect. In any event, in Windows with the following “Deader than Julius Caesar. He sold there house. It was was a big horse.” it picks up only the two double spaces and the duplicated “was” so it might not suit you.

On the Extension site a search for Grammar has also LanguageTool which needs Java 8 or later to operate which is why it can’t be downloaded from Extensions but only from the developers site. It has 3.75 stars, compared to AtD’s 2 stars.

In LibreOffice 6.4.5 / Windows 7, I disabled Lightproof and enabled LanguageTool (the snapshot of 23 August) for English (USA). Errors in ‘He sold there house’ and ‘ It was was a big horse’ were detected.

All reporting is on the Win10 version of LO

If AtD is currently working for someone, then it may be there’s an installation error at my end.

I tried a sample on AtD’s site’s demo tool (type something in this box to see AtD at work) and it reported no errors.

I don’t recall my exact test phrase but I included a double negative (e.g., “not no”), a misspelled word that isn’t a valid word (IIRC faled for failed), passive phrasing, and a misused word (e.g., “he told a lye” for “he told a lie”). All that came back from the AtD demo tool is no spelling errors.

Under LO 6.3 in writing aids there’s no reference to grammar checking. (Tools → Options → Language Settings → Writing Aids)

Under 7.0, “Itz a persunality what ‘odd Wilton’ would not want no part of” only flags the two misspellings. The Lightproof Grammar Checker (English) is checked.

Something isn’t working as I expect.

This is a screen grab of the AtD demo page.

Under 7.0, I have Lightroom Grammar Checking running. Not being able to use was only a user error. However, AtD remains as shown above.

Has anyone had success with the demonstration? Access to it is not direct. Access the FAQ page to see “Demonstration” added a tab to a page. I’m not sure why that’s not on the home page, but that’s AtD’s ,not the user’s, problem.

I installed LanguageTool. It works, it’s generally useful (some curious oversights), I’ll continue to use it for now.

An LT commented that “Write like Yoda I am…” (there’s more Yoda-ese, which I’ve forgotten - it’s a decent writing sample, though) didn’t put up any error flags. Things such as that puzzling they are.