Writer hangs when pasting big image

I’ve had this for a long time, I see many people asking about it, but no real answer.
Fedora 27,

Libreoffice: Version:
Build ID:
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-GB (en_GB.UTF-8); Calc: group

From firefox, go to google, select a large image (at least 1000x1000), right click Copy Image, go to writer paste.


Strange hang as one can still click of the close button, but still hangs.
Then at times there is a lingering soffice open and one must use “kill” to be able to reopen it.

I am telling my daughter she can use Writer rather than Word, but this does not help.

It could at least say, “Failure, Image too big”, but hanging is not really an option.


It can be any number of things. Maybe your image is exceeds maximal memory per object limit. I’m using this word processor forever now and with it can be done whatever you need it to do. Try to download image and go InsertImage. What that gives? If this work, than problem is not due to image size. The thing you didn’t get ‘Failure, Image too big’ proofs that. Might be problem with pasting from Internet. I got similar behavior when pasting large tables.

Are all images that you tried to paste from same web-source? Can you link/point to particular image as it does not happen with images I tried. Also, do you copy image by right click and choosing Copy image, or you select text around image and image and copy that? My guess you’re pasting HTML markup for tables along with image and that can cause problems. See bug report: 45307

If I download the image and insert it, it works.
But Copy / Paste does not.

Try this

1200x675 I got it searching “New York” on Google and going to pictures, it is the 4th for me.

Same happens if I open the image in GIMP and Copy / Paste.
But as soon as I resize small (less that I said earlier, about 500x…), the it works (copy/paste).

Btw, to be clear, I copy / past with the right click, no selecting or HTML markup, as I said it happens from GIMP as well.

It works for me on Debian Stretch. Maybe problem with copying on Fedora and not related to LibreOffice at all… Maybe someone else can help. Good luck.