Writer: How to keep a footnote from breaking/continuing to another page?

I’ve already set the amount of a page that can be devoted to footnotes. But I’m still getting footnotes breaking and continuing to another page, especially when I go back and edit or add to the original footnote. Am I missing a setting?

Libre Version:
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: en_US

OS Win 8.1, English.


You can Right Click text of a footnote▸Edit Paragraph StyleText Flow tab▸check Do not split... & Keep with next....

But FormatPageFootnote tab▸Footnote Area: Not larger than page area allows the notes to fill great space on the page. I’m surprised so, may be I do not understand very well the question. Could you elaborate?